Western Digital My book Essential drive help please!

I have a western digital my book essential drive. I never set a password (my bad) and the drive has locked itself and cannot access. Ok…fine I accept this so now I need to erase drive so I can use it again this time making sure to do the password thing. Here is my problem. When I try to do a drive erase under the WDSmartware settings menu I get a message “there has been an error erasing your drive”. Ok so tried to erase by entering wrong password 5 times then get the option to erase drive that way. So I say I understand and attempt to erase drive that way. It goes through the process for about 30 secs and then I get the same message again “there has been an error erasing your drive”. I have tried it both ways at least 10 times each and its always the same. What happens if I remove the drive from the enclosure and install inside puter…is this possible with this drive? Don’t care if it is erased just want to be able to use a drive I paid for. At this point I am a bit frustrated. So anyone know what my next move could be? Thanks in advance for any help!


I recommend you contact support in order to get assistance with this. It is possible the drive has failed and you need to get it replaced.

Contact WD