WDTVLiveHub does not connect to the internet.Cannot browse hub

Hello, I am new to the community but looking for some assistance to my issue.

Lost the ability to browse my WDTVLiveHub and cannot connect to the internet on the Hub either. When i connect to the network via the wireless signal it tells me network was setup successfully, on the Check Connection page, IP is checked, DNS is checked, Internet connection red x.

I recently migrated from wireless via the Cisco DPC3825 Modem, to using a Dlink DIR-835 Wireless Router. I had the Cisco DPC3825 put into bridge mode for this. I can connect to the internet and browse files with my WIndows 7 desktop via Dlink DWA-566, Macbook, and get wireless signal for iphones and ipads.

I have the WD TV Live Hub Media Center with 1TB disk using FW 3.06.14 connected with a Dlink DWA-160vA2 dongle. I have network share turned on, DNLA turned on. The network dynamically sets the IPs 192.168.0.x. I don’t have any firewall rules on the router, factory settings, set up two SSIDs using WPA2, one in 2.4 Ghz and one for 5 Ghz, both are running strong. I have tried changing the workgroups. At this point i am at a loss.

I have tried power cycling the unit that does not help. Resetting to defaults do not work.

If anyone does has any input, it would be greatly appreciated.

Have you tried connecting the Hub using Ethernet? Do you receive the same results?

Try the D-LINK forums too they’re very helpful over there. Maybe they can be of assistance. They have a forum specifically for the 825. I think it’s the same as the 835 because I see people discussing the 835 in there… I think yours has N750 as well for HD streaming.

I have a D-LINK DWA-130 and just ditched my Netgear router for the DIR-825. I couldn’t be happier. Works great.

What I did was into my router, under Network Settings there’s a place for DHCP reservations. On the bottom of that page it says add DHCP reservation. I put all my MAC addresses in there, so my computer always gets, my Girlfriends PC gets 101 and my Western Digital gets 102. I’ve had virtually no troubles at all anymore.

I may have mistakenly put the WD MAC address when I should have put the DWA-130 MAC… does it matter? I’m not sure. Right now things work and I’m not going to go fooling around.

Hey there,

Thanks for the suggestions, i have not been able to respond as i had some account issues, but those are now sorted out. I have the same set up as you as to reserved IPs for networked machines/devices. I am still not sure what it is, i have modified the router settings to what you have have WPA2-Personal and AES set now. I have enabled Netbios over TCP/IP under WINS. I have enabled NetBIOS broadcasting on the router. I have set the Windows 7 (64-bit) to use the Work Network settings. I am running the latest firmware for the DIR-835 as well, v1.02.

Workgroup is the same on Windows 7 and Windows XP and also WDTVLiveHub

Every machine in my house. Windows XP Laptop, Windows 7 Desktop, Macbook, iPad2, iPhone4S, iphone3G all are connecting to the internet fine and all shared folders are viewable. When it comes to the WDTVLiveHub it still gets the DNS and assigns an IP (so it is attached to the network), it just does not get an internet connection and no other device can browse it, thought i can ping it, i can see the dongle responding to network requests, still shows up on the network map though behind a “Bridge” with the same MAC address as the WDTVLiveHub which as i just checked is the MAC address associated with the DWA-160vA2 USB dongle i am using.

I will follow up with your suggesting and see if the folks on the D-Link forums have any advice.  I am really at a loss, though i am enjoying the wireless network education i am getting. I just hope i can hit a resolution.

As to why i have not tried to use a wired lan connection to network the WDTVLiveHub is that i had this previously working with my previous set up, i don’t have the wire where it is going to be set up (i would have to dismantle my current set up), and i am not ready to give up on the wireless yet.

Thanks for the help so far. If anyone else has any input please let me kow.

Ok to follow up on everything so far.

I have spent the last couple of days working with someone from Dlink to troubleshoot the router. We have come to the conclusion that the router is working as intended. As all other devices on the network can reach network shares and can connect to the internet, all wireless. (Windows 7 64 bit, Windows XP laptop, Macbook)

Could it be that, when i modified my network, that some settings on the WDTV Live Hub were not released/updated so that now there is some conflict with my network?

I tried to connect to a network share from the WD TV Live Hub and could see my network share on my Windows 7 machine. I tried to connect as anonymous, as i have my group policy set to allow anonymous to connect as Everyone, and could not authenticate, could not authenticate as a user from the Windows 7 machine.

I can see some service requests coming from the WD TV Live Hub.

Is there someway i can flush the settings, i have power cycled the device, i have reset settings. So far no changes. I am wondering if there is something i am missing.

Shot in the dark, but I had this problem before & my 9 year old son stumbled on the solution for me. On my D-Link wireless dongle, there is an orange button. Once pressed, everything was fine…

Thanks for the suggestion but no dice. I have reset to factory settings three times now. While lamenting i could not figure this out i noticed that with the latest firmware i could not see Netflix listed in my apps. I am not sure why. So my next task is to downgrade the firmware and see if that works.

One thing i noticed is that on my Network map shown on my Windows 7 box. I see the my router which connects frist to a device called “Bridge” which is connected to the “WDTVLiveHub”, the interesting thing about this is that both these devices are showing the same MAC adress, which is the MAC address of the USB dongle. Anyways, another day, another attempt.

Ok, been away for a while and have tried many things. I have rolled backmy FW decrementally from  Release 3.06.14  to Release 2.08.13. At least i can now see netflix. I have played around with my wireless settings and can now see the WDTVLiveHub on the network.

The WDTVLiveHub is in the same workgroup. Here is the network map.

Network Map

I can ping the WDTVliveHub and it shows up using Net View from the command prompt but if i try to navigate to it, it says it does not accept incoming connections. Still not able to access the internet from the device. It has been assigned an IP to the MAC address of the dongle. Multicast is enabled. uPnP is enabled. I am preparing to start incrmenting the firmware to the latest but i don’t believe i am going to see any results.

Did you try it without the bridge to see if that is where your problem lies? I am not knowledgeable on networking, I use powerline adapters throughout my place…

Actually the “Bridge” has the same MAC address as assigned to the WDTVLIveHub which is the MAC Address of the DWA-160 USB dongle that i am using. I find it strange that they show up as different devices.

Well just thought i would update. I finally gave up and moved were i had the wireless in the house and now have connected the WDTVLiveHub via wired LAN. It is working so i think it might be the settings i had set on the router for wireless. 

Anyways, thanks for the suggestions.