Wdtv media player suddenly not reading my hard drive

Hi everyone
I’m having the same problem. I suspect Windows 10 has done something to my WD My Book 3TB so my WD TV Live no longer recognizes it.
It was working fine until I lent the My Book to a friend to copy some media files. When it came back the WD TV Live no longer recognizes the drive. My win10 pc can read it ok and I’ve tried removing the .WD Live folder. That hasn’t helped. I’ve also run checkdsk on the drive and also used Disk Management to remove the allocated drive letter. Still hasn’t worked. The media player can see other USB sticks and enclosure drives.

When I was first loading the drive with media my PC was win7 and I hadn’t connected the drive to my PC for the last 2 years as I added new media via my network. My pc is now win10.

My friend had the WD My Book connected to his win10 pc to copy my media files to his pc. I’ve been looking through the web for solutions and one common theme seems to be win10.

I think win10 has changed something which my WD TV Live can’t deal with.

I don’t have a solution but will keep trying. I suspect I will have to buy another drive and copy my files to it the slow way via my network to keep it away from win10.

I have a WD TV Media Player (2nd Gen) bought 18 months ago. It is updated to the latest Firmware & I have gone through a complete reset where it reverts to it’s factory settings. I use it to play movies from external portable 2TB HDD’s. I have eleven HDD’s (one bought yesterday).

Four are WD, the rest Seagate.

For many months, all of the HDD’s were recognized by the Media Player, in both USB ports. A few months ago, one of the HDD’s was not ‘seen’ by the Media Player, can’t remember which one as I just thought it was something wrong with the HDD I plugged in then. I bought another HDD yesterday & it is not seen.

I now connected all the HDD’s to the Media Played and found that four of them are not seen. The four WD are seen. Three of the Seagate are seen.

All are seen on the three laptops at my house. There is no error messages when they are plugged in. They work as they should.

I have another Media Player, the A.C.Ryan PlayON!HD PV73100P+ which is 6.5 years old.
It sees and plays movies from all the eleven HDD’s.

I spoke to the shop where I bought the WD from, offering to demonstrate all eleven HDD’s, with both the WD & AC Ryan. They declined (I suppose they did not want to spend the 30 minutes it would take) and they loaned me a Media Player of a different brand, that has USB in and HDMI out. (only has two channel audio). Hooked up at home, that Media Player recognized all of the eleven HDD’s and played movies off each HDD.

Logic tells me that there is something wrong with the WD TV Media Player. I am not a ‘geek’ only a retired Motor Mechanic. I think that whatever electronics the WD used to recognize HDD’s plugged into it’s two USB ports, is flakey in this unit.

The shop is sending the WD Media Player to WD in my country (NZ). I asked the Manager to mention that they need to try it with Seagate HDD’s, to avoid it being returned as ‘no fault found’.

What are your thoughts?

Hi,

Are ALL of these portable drives 2TB capacity? If some are more than 2TB, the media player may not be reading anything higher than that. It could be the way they are configured (GPT vs MBR) (I could have these abbreviations bunged up, but someone who knows what I am trying to say can correct me, please)

Are the problems with the newest drives?

I may have mentioned this to you already, but for the money you keep spending on these drives, you could get a pretty nice My Cloud NAS with more capacity and without these issues you are having.

Hi.
Thank for replying. No Drive larger than 2TB. The 4 WD Drives that are ‘seen’ were bought in Dec 2013, June, July & Dec 2016. The 3 Seagates it ‘sees’ were bought in Nov & Dec 2015 and Nov 2016. The 4 Seagates it does not see, were bought in Dec 2015, August & Sept 2016, March 2017.

As you can see, a Segate it ‘sees’ was bought in Dec 2015 & a Seagate it does not ‘see’ was also bought in Dec 2015. It appears that it is not age related.

Yes, you are correct in that you have mentioned a NAS before. It looks like I may have to go that way. As I have all of these external HDD’s, is there such a thing as a ‘no-bay’ NAS?
I mean, a box that does what a NAS does but instead of mounting 3.5" HDD’s into it, just has other sockets like USB, so I can utilise the electronics & software inside of it, to play my movies from my USB HDD’s?

No, there is not a no-bay NAS, although there is s diskless NAS that one installs their own disks in ,or say a 4-bay NAS populated with two disks now, and the other two for a later time to expand the NAS capacity.

I would suggest buying a NAS that is not diskless; costs are similar and WD puts the correct disks in it.

To explore your options, go to wdc.com and look at the My Cloud product section for the more basic NASs and Network Attached Storage (aka NAS) section for the more advanced ones. Have fun.

Since you have all your data already on separate disks, you would not need to backup your NAS; you already have a backup after you copy all your individual files to a NAS, The task then is to keep the individual drives and NAS up to date as you move forward.

I too suspect windows 10…my WDTV drives haven’t ever connected to my Windows 10 machine up until a few days ago. For years it’s been Windows 7, Vista 64 and xp but once the drives encountered my newly upgraded Windows 10 boot partition they refused to be detected when reconnecting to the WDTV and WDTV Live boxes via USB. Luckily I kept Windows 7 in a dual boot configuration with 10 and sure enough I re-connected to the same machine but under Windows 7, shutdown after a disk check (no problems found) and the drive showed up immediately once re-connected to the WDTV.

This wasn’t isolated to my WD TV and WD TV Live boxes…it also occurred on my MyGica 1800e media player…drives copied to from my Windows 10 machines refused to mount. Multiple drives from WD and Seagate ranging in sizes from 1TB to 4 TB sitting inside multiple models of vantec enclosures. All this seem to happen fairly recently with the MyGica box after the Windows 10 creators update. Before that zero problem mounting for several months of file updating via Windows 10 and the MyGica drives all via esata.

Have been banging my head against the wall swapping drives into enclosures, deleting partitions, formatting in multiple OS, surface scans, diagnostics…and all it took was visit back to Windows 7 and the WDTV was back to life.

I’m reading some unsettling messages in hundreds of threads related to a bad driver patch related to portable devices like external hard drives in the Windows 10 anniversary and creators updates.

Hi mmicc

You are correct. It is definitely Windows 10. It changes something on the drive. As you say to fix this problem you need to access a PC with Windows 7 or earlier. I fixed my 2 external hard drives by taking them to my workplace which used Windows 7 and connecting them to my work PC. I then had the work Windows 7 PC run a check disk on each drive. It reported no errors but when I took them home my WD Live media player could now read them again.

So unfortunately we need to keep our hard drives away from Windows 10 and transfer files by using wi-fi.

Regards, Steve

Sorry you folks are having issues with Win 10. Both my Win 10 and Win 7 laptops work fine with my WDTVs. My Win 10 could see and use media files from my WD NAS, but not to a drive connected to the PC. It turned out the problem was because the drive was connected to a hub on the PC. After I removed the drive from the hub and plugged directly in to the PC’s USB3 slot ALL works fine.

I can confirm that running this freeware version of checkdisk under Windows 10 did cause the disk to show up again on my mygica 1800e media player. It should also fix it for WDTV and I’ll confirm that later. This solution has been discussed in other threads in these forums.

Unfortunately without ejecting the media for safe removal prior to shutting down windows the problem remained or returned. I’m guessing Windows 10 re-introduces whatever problem it causes that checkdisk fixes during a system shutdown. So long as you run the checkdisk utility and safely remove hardware for disconnection Windows 10 can’t pass the bug along to something that is no longer physically hooked up during a shutdown.

http://www.majorgeeks.com/files/details/checkdisk.html

1 Like

I recently purchased a second-hand WDTV p/n WDBPUF0000NBK and a WD Elements Portable 1TB drive to use with it. The WDTV could not detect the “local storage” USB drive (NTFS).
Tried a disk check, deleting the .wd_tv folder and a format and reload, to no avail.
I reformatted the drive to FAT32 and there are now no issues. Could not format to FAT32 with Windows10 except by using the command prompt (“format /FS:FAT32 H:” where H is the drive letter of the USB drive), or by using 3rd party software - I used EaseUS free partition manager.
Might help?

My WDTV Live couldn’t read my 2tb wd drive yesterday after copying a file over to it from a Windows 10 machine…but that’s nothing new. It can never read the drive after Window 10 “touches” it. Are you certain you aren’t encountering the same problem?

My guess is it touches something in the NTFS properties (security descriptors or journal entries) making the drive un-mountable until I run the freeware version of checkdisk and eject the drive before shutting down windows. Works every time…until I forget again.

I’m sure that you are correct, as Windows10 is only a recent addition (as are the WDTV and Portable drive) and I’m pretty sure I tested The WD units successfully from the Win7 os.
However, it is great to regain operation via the FAT32 formatting, and as yet loading files piecemeal from the Win10 os is working???

It’s a solution but limits your file sizes to 2 gb? That was never an option for me.

FYI for all those people having issues with your WDTV live detecting hard drives, I have discovered that Window 10 can cause file index entry errors that the Windows 10 check disk error function does not detect. The errors can be introduced when copying files from an Windows 10 PC to your drive. In my case it was a Seagate 3 TB drive. The following are the symtoms:

  • The seagate drive functioned correctly with the WDTV live prior to copying files
  • Files are copied to the Seagate drive using a Windows 10 PC.
  • After re-connecting to the WDTV Live, the “connecting to USB drive …” appears momentarily but the drive is never detected
  • The drive works fine with a PC and the WINDOWS 10 check disk error function does not detect any issues.

Solution:

  • Connect the the drive to a Windows 7 PC and run a check disk. It should detect numerous file index entry errors that it will correct
  • Delete the .wdtv directory on the disk and reconnect to your WDTV Live media player
  • You should see the “connecting to USB drive…” message followed by “compiling media library”

It should work as before. In my case 19 file index entry errors were detected by the Windows 7 check disk function

They were probably introduced whey I copied the files using a Windows 10 PC.

I hope this works for you!

Hey guys,

My WDTV Media player not downloading torrents, i always use P2P in download app to download movies. i didn’t use my WD for some time. when i recently tried to download movie its not getting download but its reading files in my external hard drive(wd my passport). please try to help me guys

Hallo, my wdtv is ssuddenly showing : internal hard drive decoupled !!
Anyone has an idea how to fix it?

Had the same problem. Just deleted the. wdtv folder, did a disk check which found no errors, plugged it in again and it worked. All on Windows 10, so you don’t necessarily need to connect it to a Windows 7 pc

Hey Susan,

I know i am too late to reply, but I have got a sure solution for your problem!
I must tell that you might have bought a new drive as its been 2 years since you posted. I have been sent here because I faced too the same problem, and thus WDTV LIVE forums brought me here.

Solution:

I know your drive is working efficiently with you Windows Pc. And that Joey have stated, Windows configured your Drive settings, is correct.
Windows modified it according to its latency to provide User a better interface and options on WINDOWS platform. So, Your WDTV wasnt able to decrypt the settings _ made by YOUR Pc.

Now your step ,

Go and delete the $RECYCLE BIN folder from your Drive. Make sure you skip the Recycle Bin setup when you are asked during deleting. You will be asked twice. Hence, Skip Twice.
The thing except the Recycle Bin setup will be deleted. This process will delete all .DAT files which were induced by your Windows.
If you are unable to find the folder, go through hidden items in your drive. To see hidden items, Open Your drive and Click on View on top of the window. Check the HIDDEN ITEMS box to enable them to view.


You no need to delete the .wd_tv folder as its not gonna make sense. You will now find a folder named folder.000 , Delete the folder - disregarding its content. I bet your drive is Safe.
You are now ordered to refresh the page about thrice.
If you are unable to find the folder.000, go through hidden items in your drive. To see hidden items, Open Your drive and Click on View on top of the window. Check the HIDDEN ITEMS box to enable them to view.

Now, unplug your drive by the Safely Remove or Eject option. If the computer says that the drive is open somewhere, and so you cant eject, follow me. Do the Safely remove or Eject procedure twice or thrice till it says that YOUR DRIVE IS READY TO BE UNPLUGGED.


Again connect your drive and see if all your hidden items have got its way back. If not. Repeat the steps above. If there was nothing to be restored (hidden items), See if your deleted folders are ACTUALLY deleted.
If you think anything is wrong or unchanged, Repeat from Scratch. This time it will surely be done because there are chances that your windows pc have declined all changes and restored everything the very first time. Repeating will ensure that windows doesnt retry its mistake.


Plug your drive into your WDTV and see if you have got your disk back. I am da.mn sure that you havent got me wrong. Also, there are chances that Videos wont get played on player. So, Unplug from WDTV and Plug Again.
If you still have any queries, email me on MKCVINE@GMAIL.COM!
There are chances that I dont open this forums again, so better email me. I am always there for ANYTHING and ANYONE.

Thank You

I confirm that the tool fixed my problem on my external HD… Scandisk with the tool where Windows 10 corrupted the disk! Thanks!

Yesterday I had the same problem (I know the post is older than that). And after reading all the answers, the solution for my problem was checking the hard drive in a windows 7 pc. My problem began after connecting the hard drive to me new computer with windows 10. Thanks for the info!