Wdtv media player suddenly not reading my hard drive


#1

I have a wdtv media player and I have all my shows on a 3tb wd elements desk top hard drive, all of a sudden my wdtv isn’t recognising my hard drive it reads no drives connected. I can still access my files using my lap top without any problems, has any one come across this problem and how do I rectify it? (ps: I do have an older wd drive and the media player is reading that one).


#2

1st thing to try is run a Windows chkdsk to scan for and fix errors
(which usually happens when you don’t “Safely Remove” it from either your PC and/or WDTV)


#3

Thank you Joey, I shall try that and let you know the outcome.


#4

Is the drive directly connected to the WDTV. or is it connected elsewhere on network?


#5

I tried but still the same, thanks.


#6

can you clarify mike27oct’s question please …

Is the 3TB connected via USB to the WDTV or connected via Network / Media Shares ?

if it’s USB … try

  • both Front & Back USB inputs on the WDTV
  • delete the .wd_tv folder on the 3TB HDD
  • press the RED Source Button on the Remote Control and select “Local Storage”

#7

The 3TB is connected directly to the WDTV. I have tried all your suggestions and my TV screen reads “content source not found”.


#8

Hi Susan,

Just for clarity, I will ask, are you clicking on the Video icon to start, and then clicking on Local Drives, because that is what your drive is by being connected to the WDTV. If answer is yes, so far, so good.

The comment on screen means the WDTV cannot detect the presence of the drive plugged into it (for whatever reason).

If you have not tried turning off the WDTV completely, and turning off drive as well, then please try doing this. First, to turn off WDTV completely you must unplug it from the wall socket. The drive also has a power supply, so unplug its power supply at wall after turning off the WDTV. Check to see that the drive’s USB cable is still into the WDTV. You can even unplug and re-plug it into the WDTV now for good measure to be sure it was well connected…

You are still at a point where everything is turned off. So, to turn it back on, do the reverse steps. Plug the drive in first to the wall. Wait a minute or so while it spins up. Next, plug in the WDTV. Once it is all powered up does it work with the drive now?. Let us know.


#9

Hi Mike, yes I am, the 3TB drive and the WDTV have been working well together for months until a couple of days ago, nothing out of the ordinary happened. Followed your steps but still the same. Its seems strange to me that the WDTV works with my old drive and that the 3TB works with another brand TV media. I have even changed the power cord and the usb plug.


#10

OK, so we know a different drive works, so seems WDTV is OK, and the 3TB drive works on another TV/device so drive seems OK.

Have you taken the drive off of WDTV, and put it on a computer a Win PC or Mac?) to see if the computer tells you the drive has errors and wants to scan it? If you haven’t, then this seems to be a next step. If it’s a Windows PC,go ahead and let drive be scanned.

While you have drive on computer, look for a folder called .wd_tv. If you see it, delete it. It is a database file the WDTV writes for the media files on the disk. It can get corrupted, and it is OK to delete it, because if the folder is not there, the WDTV will just write a new one that is fresh and clean.

If you don’t see this folder, it is because you don’t have computer show hidden files and folders, and that will have to be fixed so you can see this puppy.

OK, I am on West coast of US and gotta go for now, it is past my bedtime. Maybe Joey will be back again while I nap since he lives down under in OZ. Later, Mike


#11

Hi Mike, firstly thank you for all your help and time.
I have done everything you have suggested. The 3TB works fine on my lap top (windows 10) I deleted the wd_tv file a few days ago and it hasn’t made a new one. On searching the advanced files in the hard drive properties the only thing I can find unusual is ‘Event 410, kernel - PnP’


#12

I’ve only ever used Windows XP & 7 and been using WDTV’s since Gen1 Days …
and have never had a Hard Drive that is not recognised

and have never even heard of a “Event 410 kernel - PnP” error until now.

from a quick Google search … it’s could be a Driver Issue, Damaged / Corrupt Partition or a Hardware Malfunction ???

Dunno what the problem is … or how to fix it, but i would highly recommend that you have a Backup of your 3TB HDD … “just in case”


#13

Susan, The reason a new .wd_tv folder has not been made is because the WDTV still cannot recognize (use) the drive. And, I agree with Joey’s comments, assessment and recommendation . I have never had an issue like this nor have the WDTV reject a drive either. I HAVE heard of issues with the 3TB Elements drive on WDTVs, and this one was so hosed that it was totally unusable. 3TB drives have come way down in price the past few years so I suggest you get a new 3TB drive, and since the bad drive still works with the PC, to copy all your data from it to a new drive and use the new one on the WDTV.

What do you think, Joey?


#14

Hi Joey, thanks for your help I think I have exhausted all avenues my last resort is to reset my WDTV. Thank you to you and Mike for all your help.


#15

Let us know how the reset goes. And, you know you will have to set it up again. Good luck.


#16

I personally had no issues with my 3TB and 4TB Elements when i was using my WDTV (2004 Media Player and the Live Hub) and no issues either on the RPi2


#17

Well, whatever the case, do you agree that Susan’s drive has gone poof or not?


#18

I dunno
If it’s just a damaged or corrupt partition … then re-formatting the drive would (should?) solve the problem.

But she would have to buy another one to make a Backup 1st before re-formatting


#19

OK, since she needs another drive for “backup”, so she should copy all data off drive 1 to new drive 2, and use #2 on WDTV and keep original for a backup, and/or possibly reformat for other use.


#20

yep, either way i guess …

and can sleep easier knowing there is a “backup” just-in-case

my drives :slight_smile:… 3TB Drive1 (3TB Drive2 is Backup) 3TB Drive3 (3TB Drive4 is Backup) 4TB Drive5 (4TB Drive in enclosure is Backup) … all WD of course :wink: