WDTV Box Won't Read External Hard Drive


#1

I’ll plug in the external hard drive (a WD 1TB drive), but the interface won’t read from the drive. The WDTV just acts like nothing happened. I think I’ve done everything posted on this forum:

  • Run a chkdsk on the external drive for errors (no errors found)
  • Deleted the wd_tv folder on the drive
  • Reformatted the drive multiple times - it’ll work like once, then the WDTV won’t see it anymore

Any other solution I’m missing?


#2

what format ? NTFS, FAT32 etc


#3

Oh, sorry, NTFS. I tried changing it to ExFAT too, and that didn’t resolve it.


#4

well, ExFAT is not supported … NTFS is, sorry, i don’t know what the problem is then ?

the only silly i can suggest is pressing the RED Source button on the Remote Control
and select “Local Storage”


#5

Hmmm…yeah, tried that too of course, and it asks me to insert a media source.


#6

tried both USB ports ? front and back ?


#7

Yup, I did. Multiple times.


#8

sorry, can’t think of anything else except trying another USB Cable or another HDD

i don’t understand … i have 3 1TB WD Elements SE HDD’s and they have all worked in all my WDTV’s without any problems.

sorry :confused:


#9

Thanks for the suggestions at least. Yeah, it used to work fine on the WDTV, and then now it just never reads. I’ve tried another USB cable too, with no resolve.

Every other device reads the external HD fine.


#10

I am having the same problem. A WD TB HDD was attached and working with WDTV. I detached it, probably without turning off the WD TV and attached to my PC. All was fine. I reattached to the the WD TV and it was not recognized.

I took off and deleted the WD TV file, i reset to factory setting the WD TV. The drive works perfectly on the PC. WD TV can’t see it. This is totally defeating the purpose of WD TV for me.

Hoping for some good advise for a fix.


#11

Sadly I have the same problem…


#12

I wrote to customer service and the advice was to reformat the HDD. I will give it a try - no more options seem available or untested.


#13

I’ve tried that as well Hshrader, and it works a couple of times before the WDTV reverts back to not reading the hard drive. It’s really frustrating.


#14

Are you pressing the Eject button on the remote before pulling out the usb cable from the WDTV? You need to press eject, WDTV will then ask you which drive you want to eject, select the one you want, press OK. A green tick will appear, you need to press OK again, now it it safe to pull out the usb cable. If you don’t do this then it won’t read when you plug it back in.

Same thing on your PC, you can’t just pull out the cable. You need to use the “Safely Remove Hardware” function on the PC. When the PC tells you it’s safe to remove, then you can pull out the USB cable.

Try this if it’s not working - plug it back into your PC. Run a CHKDSK. You might get a message saying that you don’t need to scan the drive as there are no errors, but scan it anyway. If it asks you if you want a quick scan or a full scan choose the quick one. When it’s finished use the “Safely Remove Hardware” function on the PC before you pull out the cable.


#15

Tried everything you put there ronmaz, including the CHKDSK. I mean, I guess I may have pulled out the USB drive from the WDTV when it was off a couple of times, but how do you “eject” it when the box is off?

Anyways, thanks for the suggestions.


#16

Off or standby tjhoward? If you press the power button on the remote for less than 3-5 seconds you are only putting the unit into standby. Pulling out the cable while in standby could still affect the drive. To turn off you need to hold the power button for more than 5 seconds.

Try CHKDSK /F or instead of CHKDSK, run the drive error check from the Drive Properties box in Windows Explorer, i.e. Right click on the drive in Windows Explorer, Click on Properties, Click on the Tools Tab, Click on Check, Click on Scan Drive. Don’t forget to eject before removing cable from PC.

This should work. It has worked for me in the past although I’m more careful now when removing cables.


#17

Hmmm…didn’t realize there was a standby option as well as an off one. I’ll try that, and report if is working for me in the next couple of weeks.


#18

Bump. Still not working for me for some reason. Could be the hard drive, but still, it’s a WD Uhard drive.

Could it be a USB 3.0 issue?


#19

Wanted to provide an update. I ended up getting another USB drive, and it works fine.

What I did find in all of my research is that when I upgraded to Windows 10, it changed how my external hard drive was being ejected. To fix that, I went to Device Manager, then right-clicked on the External Drive->Properties, then in the Policy tab, changed the Removal policy to Better performance. This then allowed me to force an eject for my external hard drive.


#20

Whenever mine says “no source found” or whatever, it means I need to plug my hardeive back into my pc and safely remove it properly. Once I do that the wd reads the drive just fine.