WDTV - MY BOOK external drive not being recognised

Can you please help.

I can’t get my ‘WD TV’ to recognise my 4TB ‘My Book’ external drive.

When I plug the drive into the WDTV I get one of two results, either the ‘My Book’ unit flashes about four times and then the WDTV unit switches off or, on the odd occasion that the WDTV home screen appears it states there is no external drive connected. I’ve read online what I can find but nothing seems to work. Your assistance would be very much appreciated.

Just the standards questions …

  1. Is it formatted NTFS or FAT  ?  (exFAT is not supported) 

  2. Have you tried both USB inputs on the WDTV (Front and Back)   ?

  3. What Firmware are you running on the WDTV … (Setup > About > Device Info)    ?

  4. Have you run a chkdsk on the HDD ?

(to safely remove the HDD from the WDTV, just must press the Eject button on the Remote)

1 Like

Hi Joey Smyth,

HDD is formatted NTFS.

I’ve tried both the front and rear ports on the WDTV with the same results.

I have the latest firmware on the WDTV ( 1.02.17 ).

I’ve run chkdsk on the HDD with the following results:-

correcting error in index $150 for file 5

an unspecified error occurred

( 766f6c756d652e63 461 )

I hadn’t used the eject button, just turned the unit off each time so I thank you for that, although it made no difference.

thankyou for your input so far hope something above will help solve the problem…

Greyfoxx55 wrote:

an unspecified error occurred

( 766f6c756d652e63 461 )


from a quick google … that’s a error code that chkdsk failed, and looks like you’ve got some corruption on the HDD

What OS are you running ?  Win7 , Win 8 etc

have you tried chkdsk from command line ?  eg Start > type cmd > chkdsk /f X:       (X is the letter of your HDD)

1 Like

Windows 8

this was the only post i found with the error code ( 766f6c756d652e63 461 )


try the chkdsk from command line as i suggested … if no go, try (from command line)  bootrec /fixmbr

failing all of this … maybe try posting in the External HDD’s Forum to get more assistance with the error code

(i personally haven’t experienced this error, and i’m not familiar with Win8)


1 Like

Heres the Chkdsk result I just tried

Microsoft Windows (Version 6.3.9600)
(c) 2013 Microsoft Corporation. All right reserved.
c:\Windows\system32>chkdsk /f F:
The type of the file system is NTFS.
Volume label is My Book.
Stage 1: Examining basic file system structure …
256 file records processed.
File verification completed.
0 large file records processed.
0 bad file records processed.
Stage 2: Examining file name linkage …
Correcting error in index $130 for file 5.
An unspecified error occurred (766f6c756d652e63 461).

As you can see there not much at all on the HDD so nowhere as long as your example.  HDD is brand new so havent had a chance to use it yet.

also when using the command prompt  bootrec /fixmbr do you add a drive letter??

the fixmbr needs a CD (oops) http://www.ehow.com/how_10032548_fix-mbr-inaccessible-external-hard-drive.html

But, try this …

Personally, what i would do …

1)  Format the HDD (use “Quick Format”)   (backup whatever files you have on it if you don’t want them deleted)

2)  After Formatting … copy some files to it 10-20gig’s worth

3)  Run chkdsk again …

if you keep getting the same chkdsk error … then i personally would return the HDD to where you purchased it (or contact WD Support and create a RMA case)

if you “don’t” get the chkdsk error … copy a few more files to it (another 10-20gig) … run chkdsk, if all good

“safely remove” it from your Win8 PC and try connecting it to the WDTV Media Player

let me know how you go

1 Like

After what you’ve told me and the amount of mucking about so far I’m inclined to take it back to the retailer.

But I will try what you’ve suggested.  Thanks for your help and I’ll let you know how I get on.

yeah, i understand … it’s a bit of a pain

about 4 years ago bought a Brand New 1TB WD Elements HDD … copied about 200-300 gig to it

then discovered later it had a faulty USB port (would intermittantly connect or not connect via USB)

i wiped the HDD, boxed it back up and got an exchange at the brick-n-mortor store where i bought it …

the “exchanged” one has been working fine for about 4 years now :smiley:

A “superstition” i have when buying HDD’s from a store … grab the one at the back of the shelf (the ones at the front may have fallen off the shelf and been put back up)

1 Like

Did what you suggested.

Quick format of HDD, copied 20 gig of files over to HDD then Chkdsk all OK, copied a further 18 gig across then performed another chkdsk still showed OK. 

Then connected to WDTV for final test and hey presto all is fine…works like a charm.

Joey Smyth, Your blood is worth bottling mate.  Thank you so much for your invaluable assistance, it was really appreciated.

that’s good news :smiley:

as you add more and more files to it over the next few days / weeks

(or within the return / exchange period of where you purchased it)

run the chkdsk periodically just to double check things are hunky dory

and importantly, whenever removing the HDD from the WDTV press the Eject button 1st

i know i’m probably paranoid, but even before i switch off my WDTV, i eject the drive and then power down … probably not necessary … but it does give me peace of mind :smiley:

1 Like

I’ll follow those instructions to the letter mate, thanks again for your assistance and advice. I’ll know where to come next time I have a problem. Till then take care and keep up the good work, Ron