WDTV Live Player stopped reading via USB

So… (and im sure this has been covered by someone else here at some point)

Ive had 2 WD TV Live media players for several years… They’re connected to my network for some lite streaming on a rare occasion. Mostly, I direct connect, via the USB inputs, hard drives of varying sizes with various video files for playback. The units have worked very well until a few days ago. I noticed that they stopped reading my main hard drive and then a flash drive that i routinely use. I use a desktop to transfer files to these drives which i recently upgraded fro Windows 7 Pro to Windows 10. I tried other drives that i have not transferred files to (in the new Windows 10 age) and the players read them fine.

SO what now? Has Win 10 changed something on my drives? is there a work around? I have obtained the previous WDTV Firmware but am reluctant to accept and issue on the player side.

Thoughts? suggestions? Any Idea how to resolve this?

Thanks and Happy Holidays!


Have you tried resetting the media player? If not, please try that using the reset button on the back of the unit.

Lots of complaints about Win 10 and these media players. My guess is that you may need to re-map the drives you were using on the Win 7 on the Win 10 PC while the drives are connected to the media player. Look in WD Support for a mapping program for your WD TV called WD Discovery or something like that.

Done… No Change… Thanks for the suggestion, ER!

Thanks Mike… Ill give that a look but it baffles me because i dont stream… the Hard drives are plugged directly into the media player… It only seems to affect the drives that ive added files to since i upgraded to Win10…

This is what I experienced in two WD TV Live units… I could read my external hard drive on my PC but the WD MediaBox
did not recgonize the files (movies and everything else).

From the PC: Delete all METAFILES from the external hard drive
Delete all XML files
Delete all wd files
This can be done in search by typing the file your looking for. All of them will come up at once, select all then delete all at once and so forth. Then plug in Then plug your external hard drive or whatever back into the Media Box USB, At that point the Media Box will re compile information and add the new files it needs to read. Two days of screwing around reading everything I could and finding no fix. Well fixed my problem. Hope this helps others.

Thanks Sam… i tried deleting the WD folders early on, in addition to a full reset as well as a default reset from the settings… No Luck! Im going to try to downgrade the firmware next and see what happens. Im just so perplexed by this issue and its sudden appearance. In hind sight, Ive used files transferred from a Win10 installed Laptop before with no issues… Im stumped and, frankly, rather disgusted. Ive found not as good work arrounds via some USB enabled Bluray players but nothing as well organized as the WD TV Live player.

My next option may be to look at the Android based media players.

Well… So much for rolling back the firmware… Yeah! Not so much!

Guess its time to look at Android platforms…

Hope you all have a Happy New Year!