WDTV Live player won't detect my WD My Book 1TB USB after upgrading to 1.04.31_V

Anyone having this same problem or have a solution?  Neither ports on the play will detect it.  It was working fine before the upgrade.  The drive is formatted NTFS and works fine when plugged into the computer.  This is very annoying!

8 of my friends have the WD media player live - and after the upgrade everyone has the same problem.

I cant detect the harddisk. You have to unplug/plug the USB severel times and remove the power 3-4 times before you can be lucky to get it to work. But after you turn power off - the same **bleep** next day when turning it on.

This reelease **bleep** big time and it seems no one in WD cares. The dont say anythin. Are the working to fix the problem or not?   

Same problem HERE… FIX it WD

We haven’t seen this issue in our testing. To help us reproduce this issue in our lab, can you please provide the following information:

-Drive model

-Drive Part Number (P/N)

-Drive format information (MBR? GPT? NTFS? HFS+?)

-Roughly how many files do you have on the drive? Hundreds? Thousands? Are they large files? Small files? A mix?

-What operating system do you use to put files on the drive? Win 7? Vista? XP? OS X?
-Do you have any other USB devices plugged into your WDTV, such as a wifi dongle or USB keyboard?


WD TV Live:


My Book Essential 1TB:

P/N: WD10000H1U-00

Formated NTFS using Windows 7 Home Preminum about 6 months ago.

Approximately 812GB Used and 118GB Free

Content: DVD ISO files of home movies ( 3 to 4 GB each), JPEG, AVI.  Probably over a 1000 files organized in directories.

* Copied files to drive using Windows 7 when drive is plugged directly into USB.  Also copied thru network when connected to the WD TV Live player.

* No other USB device plugged to the player.

It was working fine before the update.  All I had to do was power on the player and it would detect my drive automatically everytime.  The drive was plugged in when the firmware was updated.  Haven’t removed the drive from the player USB port for about 4 months now. No new files was added weeks before the update and none after.  Neither of the 2 ports will detect the drive.

I only use this player to play content off my USB drive.  Don’t  do any online stuff.  So pretty much the player is an expensive paper weight right now.   If firmware update is this unreliable, there should be an option to go back to previous version and not leave me stuck with a useless device.

I guess this is what I get for putting my trust into a Western Digital products.  Now I got an expensive useless product.  I will never buy or recommend a WD product again.

Did you try any of the resets and troubleshooting steps in the FAQs?

One of my drives went AWOL when the update was applied, and a reset fixed it and both USB drives have been present and accounted for ever since.

Or, How to roll back the firmware on a WD TV Live HD Media Player or WD TV Live Plus HD Media Player

1 Like

If you power cycle the media player, the USB device should be functional again.

I did a factory reset and it detected my drive for few times but then disappeared again.  I rolled back to the older version of the firmware and it’s working again.  I’ll see how long this will last.  I will  post here again if it disappears again.  Thanks for your help.

I´m having the same problem… any solution?

This is very annoying, and there seems to be no solutions in the forums. Does downgrading to an older firmware works??

I have the same problem. But only on USB2 connection. USB1 works every time. Problem started with .31 and still have it with .04.

Registered just for this thread.

I recently upgraded the drive in my external enclosure to a WD 2TB Green drive. Now, the ONLY way to get my WDTVLive to detect it is to reset the factory settings each and every time the power is turned on. As soon as the power goes off, you are going to have to reset the settings all over again when you turn it back on. I have tried all the combinations of what to power up first, I have formatted/partitioned the drive a bunch of times, nothing else works.

If I stick my oooold, Maxtor 160gb drive back in the enclosure, it detects it every time no problem. It appears this problem only occurs when (ironically) you’re using 2 westerndigital products juding by the other issues people are having.

Don’t know if it matters but the enclosure is IDE/SATA to usb2.0. My old maxtor is IDE and the new wd 2tb green is sata.

my WDTVLive is running the latest firmware as well.

any ideas?? This is going to be a huge pain in the **bleep** if I have to reset the settings each and every time.