WDTV Live Hub Networking Issue

My first post here, searched all over the community, but didn’t find a solution. But apologies in case it is already there and I missed it, need help :cry:

Setup: WDTV Live Hub networked using a D-Link DWA 125 USB Wireless adapter

Wireless Router: I believe is ZyXel which was provided by the Telco.

Issue: My WDTV Live Hub connects to the Wireless n/w without any issue, I’m able to stream from YouTube etc, however I don’t find my Live Hub on the network when I try to look for it using a computer. I also tried the WD Discovery tool and it just doesn’t find the WD Live Hub. I checked the router configuration page for connected devices and I don’t find the WD device mentioned in this page, even when the router is on the wireless n/w and able to stream from YouTube. 

However, if I connect the WDTV Live Hub using a wired connection, everything works fine, I’m able to locate it as a N/W share on my computers, WD Discovery tool finds it etc, however having a wired connection is not an option since my router sits a bit far away. Also, I bought the D-Link adapter only after verifying the list of approved devices.

Please help, Thank you.

First, I don’t know a THING about Zyxel, so this may be way off base.

But what you’re describing sounds like one of two things:

    1>   It sounds sorta like the ZyXel isn’t allowing WLAN devices to talk to WIRED devices.   Check the security settings in the router.

    2>  It may be that the router **bleep**igns a whole different subnet to WiFi devices than the wired devices.

Note the IP address when it’s WIRED versus WIRELESS.   They may differ in the fourth number, but if they differ in any of the 1st through 3rd, #2 is true and will cause problems.

Tony, Thanks for the quick response.

Would like to clarify some points here though:

  1. I have no devices that are wired on the network, however I tried connecting the WDTV Live Hub using a wire only to check if that works.
  2. The IP address bleep igned to the WD Hub is within the same subnet since all IPs are of the following format: 192.168.1.X. Checked for the IP under Network option in the WD Hub, however whichever IP the WD Hub mentions, doesn’t show up as a connected device in the router config page.
  3. I’m suspecting the D-Link DWA 125 adapter to be the culprit here, but not sure and the only way to prove would be using a different adapter, which means I need to risk buying one more without knowing whether a different adapter will work or not.

Any other possible solutions?

Maybe an ip-address specific firewall rule on the computer?