WDMyCloud 4TB NAS OS5 Inaccessible after power outage - flashes blue then red

After an 8-hour power outage on a hot day my 7-year old MyCloud NAS was not recognized on the network and inaccessible via dashboard, ssh, or mycloud.com. The disk is about 50% full, ethernet LEDs are flashing green, and the power supply voltage is 12.47 volts. I tried power cycling, 4- and 40-second resets, under direction of WD customer support. I can hear the HDD spinning and seeking while the LED is flashing blue, as if booting normally, but after about 30 seconds the LED simply starts flashing red.

Suspecting the WD Red HDD might be OK, I removed the HDD and cabled it into a linux server. The server BIOS recognizes the disk as WDC WD40EFRX-68WT0N0 but with 0 capacity and is shown as an IDE slave. Output from “fdisk -l” does not show the WD disk at all.

I was hoping to analyze the HDD’s /tmp/led files to determine the WDMyCloud’s error state, try to repair any file system errors, and figure out if any files are missing from my last full backup.

Could someone please point me to member postings for repair tools and linux command line procedures for examination of physically removed WDMyCloud HDDs?

Thanks.

Perhaps try this, it should work on any Linux based NAS. Follow the link for complete detail.

Resolution

Recover data using a PC

  1. Make sure your PC has sufficient drive slots for drive installation.
  2. Remove the drives from your Synology NAS and install them in your PC. For RAID or SHR configurations, you must install all the drives (excluding hot spare drives) in your PC at the same time.
  3. Prepare an Ubuntu environment by following the instructions in this tutorial.
  4. Go to the Files on the left bar and select Home.
  5. Right-click and select New Folder, and create one or more folders as mount points for accessing data.1
  6. Right-click on the new folder(s), click Properties, the parent folder with folder name is ${mount_point}.
  • Example: If the parent folder is /home/ubuntu/ and the folder name is Test, the mount point will be /home/ubuntu/Test/
  1. Go to Show Application in the lower-left corner > Type to search….
  2. Enter Terminal in the search bar and select Terminal.
  3. Enter the following command to obtain the root privileges.

sudo -i

  1. Enter the following commands to install mdadm and lvm2, both of which are RAID management tools. lvm2 must be installed or vgchange will not work.

apt-get update apt-get install -y mdadm lvm2

Thank for the reply, but for starters I’m wondering why the removed WDMyCloud shows up in the BIOS but not as sdc in “fdisk -l” output. If it did, I think I could mount /dev/sdc somewhere in the filesystem and take a look at it.

By the way, mdadm is already installed on my Centos6 system but lvm2 is not. I do have rotating backups on portable usb drives, but there are a couple of libraries on the WDMyCloud that may have original content not backed up elsewhere. I had hope to backup directly to one of these usb drives from the MyCloud usb port, but that has never worked for me.

So bottom line, thanks for the info, but I’m still looking for the WDMyCloud HDD repair tools or command sequence once I can get the HDD recognized.

Pretty sure you won’t be able to mount and see /dev/sdc. That is the point of installing mdadm and lvm2.

But you are right to wait for specific OS5 recovery script if one is available.

OK, I removed one of the lower SATA disks, moving the WDMyCloud HDD down in the disk device list, and I installed lvm2 on centos6 (yum install lvm2). Typing (sudo lvdisplay) at the command line shows sdb info as follows:

— Logical volume —
LV Path /dev/centos/root
LV Name root
VG Name centos
LV UUID sdBvlV-K8zO-4PXv-LS2R-IEgk-wH1Z-Kf36Mr
LV Write Access read/write
LV Creation host, time uxserver, 2016-12-08 15:16:16 -0700
LV Status available
#open 1
LV Size 34.92 GiB
Current LE 8940
Segments 1
Allocation inherit
Read ahead sectors auto

  • currently set to 256
    Block device 253:0

Which does not look like an entire 4TB HDD, but following your command syntax, when I attempting to mount the LV Name “root” to /media/wdhdd results in the following failure:

sudo mount /dev/root/lv /media/wdhdd
special device /dev/root/lv does not exist

Still not able to see into the WDMyCloud file system, but listening to the stepping sounds when it tries to boot, I think it is trying but encountering a problem in the boot process.

I remember seeing a WD member post with a successful partition file check/repair command sequence, but sure cant find it now.

Your WD MyCloud NAS is showing signs of critical failure after a power outage. The drive’s odd behavior when connected to a Linux server points to possible filesystem corruption or hardware issues. To tackle this, create a disk image with ddrescue, then use tools like testdisk and photorec to recover data and analyze the filesystem. Try mounting the partition to check WD MyCloud-specific files. If these steps don’t work, search WD Community forums or consider professional data recovery. Always work on a copy of your data, not the original drive. NAS systems are complex, so approach this methodically to maximize your chances of recovery.

Kencarter556: Appreciate your suggestions, but I wonder if my clumsy approach to mounting the Ext4 HDD using mdadm and lvm2 may be contributing to my inability to reveal HDD contents?

NoPlex, the previous respondant to my post had suggested loading mdadm and lvm2 as requirements for mountin Ext4 formatted disks, but beyond the examples he provided I have no experience with these tools.

NoPlex: Reading up on mdadm, isn’t it a tool for managing RAID arrays? Is mdadm necessary for mounting a single-disk WDMyCloud?