Need help please ! no more data after power failure

Hello,

I need your help to recover all my data!

I have a MyCloudEX2Ultra 2-Bay NAS with 2 WD red 4To hard drive in RAID1.
Last Saturday, after a general power failure in my town (about 1/2 hour), my NAs rebooted.
Since :

  • I have no more access to my NAS via the windows file explorer.
  • In the NAS dashboard, the capacity shows 0MB

I have tried to reboot and reset the NAS without success. (with the help of WD support hotline). They adviced to use a recovery software to recover my files. I have tried this solution with UFS explorer recovery (adviced by WD support). but I am not a specialist and it is too complex for me.

I am sure all the data are still on my drives and I hope there is a mean to recover them.
So, I would be grateful to all those who can help me!

Thanks a lot

DON’T PANIC

OH. . . and pour out a big, big cup of patience. You may be in for some googling and learning a few things.

1st. . .I don’t have all the answers, but this does not sound hopeless. Sounds like you have a fried NAS unit (motherboard?). That does not translate necessarily into lost data. (maybe, but maybe not). I presume that Support took you through both 4 second and 40 second resets of the unit?

2nd . . .I took a glance at UFS. I am not sure this will work with a fried NAS box. BUT. . .with simple Raid1; where the data drives are MIRRORED; you may not need sophisticated software. The key is to get a hard drive attached to a working system. The drives should be identical. . .it doesn’t matter which one you hook up to a system. . . .

3rd. . . BUT. . .you probably need an external USB enclosure to make this happen. (or. . .install the drive into a PC as a secondary drive). The KEY here is that fact that the WD drives are formatted for Linux, not a PC or MAC format. Fundamentally, once you attached a drive to a working computer (say. . .through an external USB enclosure) you will need a piece of software to read the Linux file structure.

4th. . . and. . . I have already told you more than I know. I have not done this myself. If you do a search on “Data recovery” or “Bricked MyCloud”, I am sure you will find more detailed instructions (and exactly what software you should run to get the data). You can try looking in this sub-forum or the “MyCloud” subforum.

5th. … . You may be able to just get a fresh EX2ultra unit and install the drives. That just might work as well. The DEFAULT will be to wipe the drives after insertion. . .but there should be an option to simply use the drives. NOTE: for this to work, I believe you need another EX2 Ultra (i.e. something running the same firmware) This is NOT an upgrade opportunity to buy a Synology or Qnap. FWIW: If this happened to me, I would attempt data recovery using the steps above BEFORE trying a new NAS box.

6th. . . .there are plenty of people on this forum with experience with trashed systems. I am sure someone can provide more help than me.

Hello,

Thanks a lot for your reply and your help.

1 - yes, I went through both 4 seconds and 40 second resets with the WD support.

2 - This software is too complex for me. I have run it to analyse the disk 1 (I have an 3.5 hard disk enclosure to connect to my PC.

3 - I have an external USB enclosure … and an old laptop with ubuntu. Maybe, I can try to connect the disk 1? I will try tomorrow…

4 - thanks, I will try to investigate further on the web.

5 - My device is still under warranty. Maybe I can ask WD to replace it…

6 - you did a lot :wink: thanks !

Hello all,

It seems my drives are not damaged and it is only a matter of accessing the data :

thanks a lot for your help!

Hello again,

the WD support adviced to run through some operations :
https://support-fr.wd.com/app/answers/detail/a_id/21686/initiator/user

I ran the software Putty but I was not able to found the directory “Public” in which I have all the files… It seems, I just have a “photo” directory… (see attached file report from Putty)

Hello,
Nobody to help me?

Do you enable encrypt? You need to mount again after boot your EX2.