WD TV Live won't find my network share from Synology DS 213+

Hey together,

since a while I have a problem, my WD TV Live won’t find the network share of my Synology Disk Station.

AS a media server the WD TV finds the Disk Station without any problems, but when I try to go by file- or videoview and select the network share as content source, then the network share of the Disk Station won’t appear.But for example the share of my Router (Fritz Box) is shown.And with Windows I also have no problem to find the network share and access it.Before some time it worked perfectly. I got the feeling that some update destroyed this possibility.Do you have any idea?

Thanks, shirocko

it’s probably a master browser issue

you can search the forum for info about it

but I’d recommend to skip all that and enable NFS on your synology and connect that was

WD calls NFS , linux shares

yeah one of the Synology 5.x DSM releases broke CIFS shares. Just enable NFS on the Synology and use “Linux Shares” on the WDTV

Hello and thank you for your answers.

I tried to activate NFS for my share, I also tried the option of NFSv4 and different permissions, but the WD won’t find the share. Could you tell me what settings I have to set in the Disk Station to get the share working?


Nfs v2
nfs v3

Should work


sorry but no setting I am trying is working.

The WD TV Live is searching for over 10 minutes and didn’t find a NFS Share.

In attach I post a few screenshots of the settings in the Disk Station, maybe you could tell me my mistake.

  2015-01-19 19_03_08-Synology DiskStation - DS213.png

2015-01-19 19_03_17-Synology DiskStation - DS213.png

2015-01-19 19_03_31-Synology DiskStation - DS213.png

I found the solution.

I had to restart the NETBIOS masterbrowser in my network, which was my router. After that CIFS and NFS are working.

The solution is from this thread: