WD TV Live - recurring USB problem


#1

I’m using the latest WD TV live firmware.
For the past few weeks (since upgrading the firmware?) I have problems with my USB devices not being detected.
The problem happens on both USB1 and USB2 and with different devices (WiFi dongle, HD), and it seems like no device is connected to the port (even if I re-connect the device).

By disocnnecting the device from the power supply for a few seconds the problem is solved.

Any idea what cause this problem? Anyone else noticed it?


#2

Hello,

As a recommendation, try performing a hard reset since your case is the first one that I have notice.


#3

I have a similar problem…

Finally got round to updating my WDTV Live player & recently updated the firmware from 1.01.24 (out of the box) to the latest 1.06.43_v and not only does it not recognise one of my 2Tb drives (even with unplugging power), the box doesn’t recognise the rear USB port (no2) at all!

It’s gone from being a cracking piece of kit to something I’m now considering replacing -is there anyway at all that I can go back to the original firmware it came with please?!

Thanks

Hardware:
1 x WD TV Live Player - WDBAAP0000NBK-01
2 x WD Elements 2Tb HDDs - WDBAAU0020HBK-01


#4

In my case the problem is resolved by disconnecting the power plug for several seconds.

I’ve found out that the problem occurs short time after switching one of the USB devices.

I got a reply from support suggesting doing a hard reset (reset button for 10 seconds). Haven’t tried this out yet because the power plug solution works for me.

I have been using this device for several years now. I can say for sure that the problem has something to do with the latest firmware.


#5

Just out of interest, a reset is acheived by pressing the reset button for a couple of seconds and then releasing. A 10 second press will change the TV standard from NTSC to PAL or vice versa.


#6

Of course. I meant a short reset (not 10 seconds).

Anyway, even if solvable by reset, this is a bug that should be fixed. I have been using the device for long time to note that the problem has something to do with the new firmware.


#7

Cheers for the recommendations - I was a bit sceptical as I’d already done a software reset (factory settings) but gave it a go anyway. Unfortunately it’s as I thought - no change for me i.e. no usable USB2 port & won’t recognise my 2nd drive anymore.

Hoping the new update is soon and rectifies this…