WD TV Live Plus; networking issue


I am a new user of WD TV Live Plus and got the box two days ago.

The installation was really easy; well done WD.

During installation I upgraded the firmware to the latest version.

I have a 1Tb Element USB storage device and I am glad to say I can play all the video and pictures from the Element hard disk.

However I am having a few problems when trying to play video over the network from my Windows 7 laptop. On windows 7 I have shared all my stuff to “HOMEGROUP”. I am able to play files from “Public” share but can not play from any other folder.

On my Laptop I have a second hard disk where I store my AVCHD (m2ts) files.  I able to see the folder and the files underneath but whenever I try to play one of those files then it reports “File type not supported”.

However, if I copy the same file and place it in public folder then there is no problem playing the same video file.

I’ll appreciate your help.


WDTV does NOT support “Homegroups.”   You must use WORKGROUPS.

When sharing a folder, you need to share with the user “Everyone,” if you’re logging in using “Anonymous.”   If you password-protect the shares by assigning them to other users, then you need to log in to that user account from the WD.

Thanks for the reply.

Previously my laptop was in Workgroups and I changed to Homegroups to see it that makes any difference. Ok I’ll change it back to Workgroups again.

Also do I need to create an “Anonymous” account on my laptop Windows 7?

On WD TV Live how do I display the on-screen keyboard in-order to enter the user name and password?

 Also do I need to create an “Anonymous” account on my laptop Windows 7?


On WD TV Live how do I display the on-screen keyboard in-order to enter the user name and password?

You press the ENTER button.


I have tried what you suggested.

1.  Windows 7 laptop in Workgroup (changed from Homegroup).

  1. Folder shared to “Everyone”

  2. Rebooted the laptop

  3. Power down and reboot the media player.

However, the problem still not solved. I am able to select the pho/video files from Windows 7 folder but will not play the files.  As I said before I can play the same photo/video files if I copy them in Windows 7 Public folder.

It got to be some sort of permission issue. Any more idea?

By the way; I haven’t installed the “Discovery” software on my Windows 7 laptop. Is that necessary?


hi there

  • discovery seems for xp users

  • have you tried to  “map” discs on you laptop? 




No I have,'t tried that yet.

May be I need to read the document again. Could you tell me how to map disc on my laptop? I can see all my files on the “D” drive but can not play them.

No, you don’t need to MAP disks.   That’s for sharing in the OPPOSITE direction.

So, you’re saying that:

   1>  You CAN see the server and shared folder in the Network Share list

   2>  You CAN log in now.

   3>  You CAN see the files

   4>  You CAN NOT play them?


You are right. I can see the files on the “D” drive on my laptop but can not play them. Reports “file type not supported” or something similar. I can not remember the exact error message.

As I said before, I can play the files if I copy them in the public shared directory.

Then I think your guess is correct; it’s a permissions issue. 

Go right-click on a file and check the permissions of the specific file.

Tried everything and checked all the permissions etc. But the problem is still not solved.

As I said before WD TV Live is able to see the “d” drive and the photo and video files on my laptop but unable to play them.

The same files in the public folder - no problem.

Any more idea… Please let me know.