WD Networks wont recognise USB Mass Storage Drive


#1

I have tried every setting recommended and I can’t seem to get the WDTV to see the Astone USB Mass Storage Drive that is connected to my PC.  I have set sharing on the folders, added the folders to the library, along with a number of other solutions recommened in other forums but none have worked.  I had it working fine until my PC was upgraded with Windows 7 and now I can only view the Public folder on my WDTV and no shared networks.  I considered moving all my movies/videos/music to the Public drive but what’s the point of having the capability of Network Sharing and the Mass USB drive. Can anyone help, please?

steph


#2

It’s hard to say because we don’t know what you’ve done other than “a number of other solutions recommended in other forums”.  But let’s walk through this step by step.

First things first – make sure your workgroup in the LIve (which you can see by checking connections) and the workgroup in your PC (right-click on computer) are the same, including case.  The Live defaults to “WORKGROUP” which isn’t a bad thing to use on your PC as well (which usually defaults to MSHOME).

Secondly, when you share a folder in Win 7 you must add a new share – go to the shared folders, press the add button, and add “Everyone”.  It’s also a good idea to take the password off the share (you can still have a password to login to your computer if you want, but you don’t want another password on your shares).  You do that in the same place.

Finally, it may be necessary to reset the Live (there is an option to “reset to factory” in the Settings menu).  At the very least you want to “clear auto login to shares”.

If you do all these things and it still doesn’t work it probably isn’t the Live that’s the issue, but we can talk after that.


#3

Thanks for your reply Mike.  I checked WORKGROUP on the Live and PC and both are the same.  I also tried earlier resetting the factory settings.  The only thing I can’t check is the Sharing Options.  I know that “Everyone” was assigned to the Shared folders but I will have to double check later as at the moment my husband has moved the drive and plugged it directly into the Live to see if we could get it working and it does work fine.  I will get it set back up on the PC and let you know how we go with the sharing options.  It’s a bit late now (nearly 11:30pm) so I will get back to you with how we go tomorrow.

Thanks Again for your help

Steph