WD TV Live Plus Limited Public Beta Firmware Version 1.04.22_B (3/3/11)


#1

This is a limited public beta release version of the firmware. Feel free to install it, but be aware this is beta firmware we are still testing so use it at your own risk. If you are not comfortable with this, please wait for the final version. 

Do not contact customer support for issues found with this firmware.  Rather, post your experiences to this thread.  

WD TV Live Plus Firmware Limited Public Beta Release

http://www.wdc.com/wdtvliveplus_limitedpublicbetarelease/

Problems during or after firmware upgrade**  **

 

Before you rollback to an earlier Firmware ( KBA # 5800) or contact Product Support, please try some of these methods to resolve the problem you are experiencing.  Try each method to see if it fixes your issue before progressing to the next method.

The WD TV does not complete firmware upgrade:

  1. Retry by using the upgrade FW on a different USB drive. 
  2. Load an earlier FW ( KBA # 5800) onto a different USB drive to downgrade, and then try upgrading again using a different USB drive.
  3. Load an earlier FW ( KBA # 5800) and then try upgrading via online update.

 

Network specific issues:

  1. Redo Network Setup:  Settings/Network Settings/Network Setup.
  2. Clear your Network Shares logins:  Settings/Network Settings/ “Clear login info for Network Share.”  Then re-login.

All issues:  

  1. Reset your unit through the user interface: Settings/System/”Reset to factory defaults.”
  2. Hard reset by momentarily pressing a pin in the “Reset” hole on the bottom of the WD TV unit. (This will reset the unit back to defaults without eliminating any media or personal files).
  3. Delete the “.wd_tv” folder from your USB attached Hard Drive using a PC. 
  4. Reattach USB to the WD TV device.

#2

Holy Cow!   That’s the biggest release notes I’ve ever seen!


#3

I updated fine and everything seems to work so far.  However, I tried TuneIn radio for the first time and the volume is so low that I have to crank my TV up to 80-100% to be able to hear it… barely.

Thanks for the updates and supporting your devices!

Update 1: Confirmed that the volume is low only on tunedin radio… netflix and videos are still normal. 

Update 2: Thank you SOOOO much for moving the folder icon back to the lower right corner of the folder image!!!  Now my custom folder images look proper again :)  BIG THANKS WD!

Update 3: The TuneIn radio application seems to be working fine now.  I really have no idea what the problem was before.


#4

No more stuttering audio or video with this firmware. Wired-network streamed HD files play with little or no hesitation. FF/REW and PAUSE work without flaws (so far).

Updated from 1.03.49 to this with no trouble.

Thanks WD


#5

The update seems to have fixed the netflix audio problem as well that I had where after using playon.tv and then switching to netflix there would be no sound in the video. Only thing I noticed was Playon.tv videos seem to load slower now with the beta firmware.

Trallyus


#6

Loaded Beta v1.04.22_B on my wdtvlive plus and the install went smooth and so far everything I’ve thrown at it works well.  Even noticed that the stutter when playing back through network shares is gone.

I must say that the list of fixes on this release is fairly extensive and on par with the 

1.03.49_B release.

One thing I did notice that wasn’t fixed is the UI transition effect; fade in/fade out still doesn’t work.  Not a priority, but c’mon - it used to work.

Anyway, kudos so far to the wd dev team.  Keep em coming!


#7

I’m still getting the stuttering of VOB files over the Network, is it woking for everyone else?


#8

I should mention that I didn’t see the Stuttering issue as being resloved in the release notes, but with the issue thread being closed, I assumed it was fixed. I’m getting numb to this, because I’m not even surprised at the lack of a fix, but I was excited about the possibility of one.


#9

Edit:

I just hard reset the unit, and now I am successfully playing some Alison Krauss over wifi. It looks and sounds great  :)

One problem is that it does not play the DVD menu, and just goes straight into the show. It also doesn’t let me skip tracks, but goes back to the beginning when I click on the next track.

Another problem is that it seems a bit slow to access the 2 TB drive (compared to 1.04.18_B), but I’m not complaining since I can finally watch my concert DVDs.

:smiley:


#10

Dave-DNS-323 wrote:

I’m still getting the stuttering of VOB files over the Network, is it woking for everyone else?

Dave,

I just tried to play some vob movie files both using media server and network shares and they worked fine.  Just for clarity, my vob files are passthrough files of whole movies; ie., one vob file for a whole movie and not the individual vob files in a DVD menu structure.


#11

Following-up to my previous post… I have confirmed with several DVD’s that menus and next track features do not work.

Also, fast forward doesn’t work properly. Anything above 2x speed is very slow. I sure wish the dvd menus and next track features worked.


#12

dbjoiner wrote:

Following-up to my previous post… I have confirmed with several DVD’s that menus and next track features do not work.

 

Also, fast forward doesn’t work properly. Anything above 2x speed is very slow. I sure wish the dvd menus and next track features worked.

I just watched a DVD movie that was stored into an ISO file.  The menu worked fine, and when the end credits started I fast forward (2, 4, 8, 16x) until the end to see if there was a teaser at the end… and there was.  No problem whatsoever with my ISO DVD.


#13

Dave-DNS-323 wrote:

I’m still getting the stuttering of VOB files over the Network, is it woking for everyone else?

We identified the root cause of the VOB stuttering over network shares issue, and we’re working on it. It’s not fixed in this release.


#14

I just installed 1.04.22_B on my WD TV Live Plus.  I cleared the system settings and did a paper clip reset before and after the update.

Netflix audio over the optical port is still broken in this version.

If I start Netflix after first powering on the device, I get no audio over the optical port.  If I play a video file over a network share first (which works fine over the optical port), and THEN start Netflix, then I get audio over the optical port.

Please, please, please fix Netflix audio over the optical port.  Please.


#15

Hi Mr. Bill !! great thank’ you for hear our prayers … I hope that will be a good fw the offcial one !

regards & happy to see good news


#16

Guy_K,

Are you saying that VOB stutter is not fix in either the Live or Plus firmware updates?

Also, what is the root cause of the problem?  Why does it stutter?


#17

Sry wrong thread ill move over :slight_smile:


#18

Guy_K wrote:

 

We identified the root cause of the VOB stuttering over network shares issue, and we’re working on it. It’s not fixed in this release.

 

I am happy that you found the cause of this problem. This is one of the reasons that I have not upgraded my firmware since v1.03.49.

Has WD made any progress on the issue of not remembering the video resolution/frequency and color space values (when they are set manually) when the unit is powered off/on? This is a simple fix and would solve the hdmi negotiaion issues that occur with some TVs. Please, please implement this fix in the next official release!


#19

How did you do hard reset? and is there a 7.1 file, sample I can check?

My issue is info bar is so lame, it does not show you any details of audio/video files type, bit rate etc. DTS HD MASTER is still DTS core 5.1. So 7.1 will be core 7.1? no lossless?


#20

zibawal wrote:

How did you do hard reset? and is there a 7.1 file, sample I can check?

 

My issue is info bar is so lame, it does not show you any details of audio/video files type, bit rate etc. DTS HD MASTER is still DTS core 5.1. So 7.1 will be core 7.1? no lossless?

You can download test files for various audio formats from here:

http://www.demo-world.eu/trailers/high-definition-trailers.php

WD have been unable to secure a DTS-HD license, so you’re limited to the DTS core (no DTS lossless).  

DD TrueHD seems to work fine though.