WD TV Live Hub no longer appears in Explorer (Win7)


Sorry if this is a double-post.  I read around and didn’t QUITE see the same issue posted already.

Not sure if this happened because of the last firmware update or not, but suddenly the WDTVLiveHub doesn’t appear in Windows Explorer under Network anymore, preventing me from transferring files from my PC to the WDTVLive (and the external HDD attacehd to it).

The device does show up twice under “Media Devices” when you click on Network in the explorer.  When I double-click either one, I get either the Twonky media server configuration thingy, or the black background fancier looking menu with the status ticker at the bottom.

Anyone out there who understands this and can help me get the folders back under Network so I can drag and drop more files to my player? :)  Anything I can adjust using this Twonky interface perhaps?


I use Windows 7, and the player (which is upstairs) is connected using D-LInk powerline internet adapters.

Thanks in advance!  I’m a bit of a noob when it comes to troubleshooting these types of network issues.  Thanks!

Have anything changed on the configuration recently?

You can try mapping the hub’s drive?

1 Like

Thank you for the response.

Mapping doesn’t seem to work.  The device is just named WDTVLiveHub (which I believe was the default name), and so I tried \WDTVLiveHub as the folder name to map… no luck. 

I haven’t changed anything other than updating to the latest firmware.  My device and its folders always showed up in Explorer and I could just drag-and-drop new files from my PC.  It is no longer there, and again, when I click “Network” I only see the LiveHub listed under “Media Devices”.  Clicking them brings up the server stuff (Twonky) in my internet browser.  WTH?

Yup this is weird…

Try going to the router page and see the IP address assigned to the hub and try to map it that way

try resetting the hub also

1 Like

Apparently installing WD Link software solved the issue (for now, as I JUST installed it).

I did not know this software existed, and my previous attempts to map the drives manually weren’t working.   Time will tell if they STAY mapped using this utliity.

Kudos to you for your responses


Mapping the WDTV Live Hub causes more problems than it fixes.

It can really cause a slow down when you try to access the Network Folder.

This is not a new issue. It still happens from time to time, so I don’t think this issue is solved.

Sometimes Resetting the Router will do the trick, but I have never had to reset the Router or Any Other Device and I regularly use SMB Shares in Android.

One shouldn’t have to Reset the Device for this to work. There’s no way to Backup Settings in WDTV Live Hub Software either, so you lose all your other settings.

Western Digital needs to Open this software up so people can Modify firmware and fix it themselves. Please pass this information to Admins and higher levels. WDTV Software needs to be Opened up so we have more choices on what we want and what we don’t want on our devices.