WD TV Live Hub freezes after some time of playing videos


My WD TV Live Hub freezes completely after playing the videos for a few minutes. The only option is to unplug the device and plug it in again.

Again when i play any video within few minutes the device freezes.

Can someone help me out with this ?

Where are the videos stored?   Internal HD?   USB Device?   Network Share?  Media Server?

Is it ALL videos?   

The videos are all stored internally. Any video I play the same thing happens. It plays for few minutes and it just freezes. I just noticed that the device is also no longer accessible in the network from my PC . 

Does it do it with the SAMPLE MEDIA that shipped with the hub?

I haven’t tried that. But this has been working for me for the past few months and now suddenly this is happening.

Also the system freezes if I do nothing. I turned on the device and hadn’t done anything. I just left it as is at the menu screen. And after some time when i tried to navigate thru the menu, it just would not work. It was frozen.

I am not sure if something has happened to the device.

Did you add or change anything on your network?   Some people have reported their WDs freezing if something on their network has a LLDP or LLTD service running…  Just search those accronyms in this community for more details.

No, nothing has changed recently.

But I did update to the latest firmware last night and coincidentally after that only this has started to happen. But I even downgraded the firmware to the previous one and still the same problem.

Well, if rolling back did NOT fix the issue, then that means it’s not a firmware issue…   It’s either soemthing in the environment, or the hardware itself…

Did you try resetting the hub. Press the bottom paperclip button for a couple of seconds and then release with the unit fully booted up. Note - you will lose any Get info that you have downloaded but your files will be OK.

I did notice that the player freezes only when the Internet Cable is connected to the device. When I disconnect the device, the device plays without any issues. But what I am wondering is I have this same network for the past few months and there has been no change in the network. What has changed suddenly that freezes the device ???

By any chance, are you you using the GALLERY VIEW?

If so, try changing to a DIFFERENT VIEW before starting a movie.

As I told before, not just playing the movie. Even if i leave the device on the home page (with the navigation menus on the screen) it hangs in few minutes when connected to the internet.

I even tried this after switching off my PC which is the other device on the network. Still it hanged in a few minutes.

Same thing is happening to me. I started to update to the new firmware and after it downloaded and hit 100% it froze and I had to unplug and replug the device. Ever since then, my hub freezes.

Yes I too agree, this has started to happen only after I upgraded to the new firmware. But then even downgrading the software did not work.

So I am not really sure if the new firmware has to do anything with it or was it just a coincidence.

I’ve tried downgrading, and that didn’t work. Then I manually upgraded to the new firmware, and that didn’t work either. Anyone have any ideas?

I am not sure if this is a known bug with WD. I even tried calling the Tech Support for help, but no luck. They said I must have done something.


Your post is blank, are you using IE9?


Hi . I also installed the last firmware and the picture freezes after a few minutes. I rolled back to the previous firmware and everything is the same ( freezes and network problems)
(and yes… I use IE9 sorry :slight_smile: )

@tomcat76 - It works perfectly fine for me If the network is unplugged. So you might also want to try the same. Still I do not have an answer why it does not work when the network is plugged in. Neither WD Guys have an answer.

Ill try tonight !! Thank you