Help: WD TV Live freezing

Hello everyone,

After several months running smoothly, my WDTV Live suddenly started freezing during playback and fast forwarding the image, unresponsive to any remote control commands. The only solution is to unplug the power cord and restart it. I’ve used different flash drives and changed the USB ports, to no avail.

I’ve also tried using the factory reset, which made me lose my dashboard and still have not solved the problem.

What is the recommendation for this case? Is it rolling back firmware? (I’m using 2.02, which is the latest).

Thank you a lot in advance!

Cheers from Brazil


Make sure the WD TV is not overheating. Place the uni in a well ventilated place. 

Thx for the prompt reply!  :smiley:

It is actually in the same well ventilated place it’d been used for a long time before these issues.

Any other suggestions?


I have 4 units with latest firmware. The WD was freezing after 32 min even if I never watched a movie. All 4 started on the same day. This happened before a a reboot of my router fixed the issue, but this fix was no longer working. I rolled back to the last firmware and all players work 100% again.

Thx! I’ll try the previous firmware tonight. Fingers crossed! :slight_smile: