WD TV LIVE stops playing, need to restart


i have a problem with my player WD TV LIVE, use it in combination with the WD MY BOOK LIVE,
the last month is stops playing after a minute of 20, player is locked, need to restart. use firmware 2.02.032

please advice
thanks in advance

reagards Reinoud de Boer

We all have the same problem. Try to rollback the previous version of firmware.
Most of the topics in this forum deal with this problem.


has this issue been passed on to wd for a fix ?

thank you, is there a manual how to roll back the firmware?

You have full explanation in the following thread:

Sorry I copied the wrong link:

Downgrade Firmware from 2.02.32 to 2.01.86

thank you!!

How do you roll back the firmware?


Be sure your player isn’t talking to the Internet or your router when you do the upgrade (kill the player’s connection to the network), and make sure the Check For New Firmware setting is on, otherwise the player won’t see the files on the USB stick as firmware files and the New Firmwre tab won’t show up (at least that’s what mine did). Turn off auto updates, otherwise it will want to go get 2.02.32 and reload it.

thank you!

Dear MrPink,

Thank you very much your last suggestion which I did it and roll back the version from 2.02.32 to 4.01.86. And I hope the films will not freeze and the remute control
functions even next day while it is on AC power. You will not believe me but I bought myself this gadget (WD TV Live Streaming Media Player) 19 pieces to all my family and friends and everybody is suffering from freezing after 20 minutes and remute control not functioning. Thanks again for your recommendations.
Best regards / Zeki

I have a WD TV Media player that i purchased 2 months ago. Been facing the freezing problem ever since. I recently downgraded the firmware to 1.01.30 and did a factory reset. Things got better for a while however the freezing problem resurfaced and it sometimes froze 2 or 3 times while watching a 40 minutes series episode.

I usually watch my series via a shared folder on my laptop linked thru a network to the device. Does this have anything to do with the freezing as well? Should i downgrade the software further?

Any help would be appreciated.

The 4.01.86 is a bogus number designed to make the player think the version it is loading is newer than the installed version. Otherwise, I think it would refuse to load the old FW again. The version is actually 2.01.86.

Oh, and I left the “s” off of “support” in the FW link above. It’s fixed, sorry about that.

Replied elsewhere, but probably should here, too. The rollback appears to have solved the issue, but at the expense of some missing codecs and such. So having nothing to lose, I went ahead and updated back to 2.02.32. Box is now working normally and has been for 12 hours.

I wonder if the process of updating fixes something we just don’t know about? I will keep reporting in.

With roll back the version from 2.02.32 to 2.01.86 the problem is solved. :grinning: