WDTV Live Random Freezing

Hi Community.

I have a WDTV Live Gen3, it’s almost 2 years old and for the most part has been great. However very recently it has been randomly freezing while watching content and I’ve also noticed it has been getting very hot too. When the device freezes it has been on both different content and file types so I am convinced that it is nothing to do with any particular file or extension. When the device freezes it and the remote become unresponsive and I have to unplug the device to use it again.

I have tried resetting back to factory defaults, changing settings, different files and it continues to behave this way and as stated before it has only been recently I have noticed this behavior. The hard drive that is connected to the device is a 3TB USB3.0 WD HDD and is fairly new the current firmware on the device is 2.02.32 and was last updated last year.

I would appreciate any help provided with this issue and will post more information if required. Thanks is advance for any assistance.

Funny you posted this because I came on here to post the exact same problem. I’ve had 3 of them for about 3 years and recently the one in my bedroom freezes about 30 minutes into any movie I’m watching (it was running hot when I left it on top of another device, but I have since moved it’s side and not on any device). I have not tried resetting it or changing the factory settings, but sounds like that might not help. Let me know if anyone has any other advice.

The latest Firmware revision is known to have stability problems. Usually, downgrading the software manually and deactivating update search resolves the problem. Downgrade to 2.01.86 for the gen 3. See here for files and directions:

Thanks for the advice G2n3r1c. I’ve downgraded the firmware to 2.01.86. I’ll keep an eye on the WDTV and report back in a few days on its performance.

I too have been experiencing these problems with the WDTV which I have had for over 3 years. At first, I thought it must be dying but now I see so many people having the same problem. I talked a friend into buying this unit and he also has seen the same problem recently. It is about useless in this state. I can’t trust it to play a video without freezing and having to unplug and plug back in. Is it possible that the last firmware update gave us a virus?

Hi community,

I’m also experiencing same troubles since few weeks. Was wondering if i was an isolated case, well, i see i’m not!
3 relatives of mine are experiencing same issue ( we bought our devices at almost same time) and we encounter same trouble at the same time. Very weird, is that the update to the last version was made a while ago, and troubles only appears now. Thanks G2n3r1c for the advice, i’ll give it a try. Any clue of a glitch causing those freezes?
Where to find the firmware mentionned above?

Having same problems. Freezing during a video and unit freezing during sleep mode. Manual reset (pulling plug) and device reset via system setup is making no difference. Have tried multiple USB flash drives and it makes no difference, so that is not the issue.

Running firmware version 2.02.32. Have tried re-installing version 1.02.17 from the web site using their instructions, but the unit is not recognizing the four required files from the USB flash drive as per installation instructions.

Other postings in the WD Community area suggest turning off Miracast has worked for some. I’ve tried that and it makes no difference (at least not to me).

So I THINK I have found the answer (at least to my problems with no guarantees that it will fix yours). A few things to first know…

  1. I’m very confident the freezing issues most (if not all) are reporting are firmware related.
  2. The answer is (as others have recommended in various community threads) downgrading the firmware.
  3. By me doing #2, my freezing problems have disappeared.
  4. BUT keep in mind this might not solve every problem for everyone.

So what’s the best procedure? Don’t follow any instructions but those from JoeySmyth in this thread (IMO)…

…or from the cut & paste of the same below (with a few notes from me in BOLD)…

So there you go. Good luck, but all I know is that it worked for me.

To anyone still experiencing the issue in this thread, it’s time for an update. I rolled back the firmware as suggested by G3n3r1c which appears to have solved the issue. Since the rollback I have used the device three times and it has played content all the way through. I also disconnected it from the Internet to prevent it attempting to update itself to the latest version. Be it either the firmware or disconnection from the Internet the device no longer seems to be overheating. Hopefully anyone still experiencing this problem can achieve results by following suggestions in this thread. If similar issues arise feel free to post them here an either myself or the community will be able to help. Thanks again to all who helped.

Hi @GADG3T87 , I am glad to hear that I could help. FYI: You don’t have to disconnect the device from the internet. Just go to Setup -> System and set “Auto detect new firmware” to “Off”. Then it will stop nagging you and you can still use all the web apps like Netflix etc.

The reason for the instabilities propably is that Western Digital crammed new features like Miracast into the newest firmware and the device just cannot handle them. It is either badly implemented or it just lacks sufficient memory. Either way, it is simply unusable with the latest firmware. WD is aware of the fact as far as I know, but the player is already out of production so I guess they just don’t care.

I rolled back firmware, everything working as before

Thanks for all the help and suggestions. I rolled back too and so far not a single crash or freeze. My wife is really happy. Mahalo!