WD Sync not syncing certain files


I bought mycloud device a few weeks ago. I have began to setup the device and installed WD Sync and Smartware.

For the WD Sync I wish to sync certain folders on my computer. I first synced my downloads folder and everything was fine, it was a mirror and sync worked. However, when I synced my pictures folder using WD Sync all that was created on the mycloud was the folder structure with no files at all inside the folders.

I thought this may have been a mistake in setting up so I fully factory reset the device (probably a bit extreme but wanted to make sure!). Now I have tried starting from scratch again to sync my pictures folder and the same thing happens, the folder and subfolders are there but no files at all inside.

Does anyone know what is happening?



Make sure that those files are not protected. Also, you can try reinstalling the software and setting up the folders again.


The files are not protected. I have tried reinstalling the software and still the same problem.