WD Smartware Excessively slow backup on PC

I recently purchased a WD MyCloud Mirror. I have a mixed network with both a Mac and a PC, All devices are WI-FI (802.11n) except the NAS which is plugged directly into my router’s #1 ethernet port.

The Mac performed a full time machine backup in about 5 hours (250GB).

The PC is on day 2 of trying to backup less data. Watching my network transfer speeds on my PC, I see them barely exceeding 1Mbps on average. I did some internet speed tests just to make sure it wasn’t a problem with my wireless NIC and I saw the speed push up to the limit of my broadband connection so I know my LAN is capable of faster throughput.

I also tried manually copying files to the NAS via file explorer and saw the speed jump up to an average of 100Mbps. The problem is definetly with smartware.

Is there a way to tune smartware to run better than this? I almost wonder if I’d get better performance from Windows backup? I like the idea of a smart backup that targets certain file types to make the process easier but if it’s going to run this slow, I’d have a better experience with a more manual process.

Any ideas?

WD SmartWare Pro - Version 2.4.2

WD Mycloud Mirror - FW 1.05.21

Mac - OSX Yosemite

PC - Windows 8.1




Try uninstalling and reinstalling the WD Smartware software.

Same problem here: bought a WD My Cloud Mirror (8 TB) yesterday. Now backing up files from my (fairly new, Windows 8.1) PC using SmartWare, but it is extremely slow: it is chewing on even the smallest files for ages (8 - 12 seconds), one, by one, by one. It has been going for over 9 hours on an initial backup, didn’t get further than 19 GB in that time.

As suggested, I stopped the backup, uninstalled SmartWare, rebooted the PC, re-installed SmartWare, but the result is exactly the same. I have the most recent version (v 2.4.4), and the latest firmware on the My Cloud Mirror (v 1.05.21).

Network, router and switch are 1 Gb/s. I do see the CPU of the My Cloud Mirror is nearly 100% busy.

What could be wrong?

I have the same issue/problem on a Windows 7 machine and My Cloud EX2. It is really too slow to be usable. Any ideas appreciated. I also see the CPU of the EX2 to topped out. It will also go through long pauses where nothing is transfered. I have the latest Firmware update on the EX2 and the latest version of the SmartWare. It can not be this slow for everyone or no one would/could be using it. Thanks in advance.

Almost two weeks ago, I bought a 6tb MyCloud based on WD’s claim:  

Fast backup

My Cloud is on your own network, so backing up is much faster.

Riiiiiiiight.  12 days later, it still had 19.5 gigs left of 1.2tb and seemed to be getting exponentially slower as it progressed.  I left it going more out of morbid curiosity than any expectation that it would finish.  I did manage to complete backups of a tablet and a couple laptops that had less data and fewer files but it still took a ridiculous amount of time for each of them.  Over two days for just over 13 gigs from my tablet.  Even over wireless, I average 5-5.5 MB/s.  Moving that much data should have taken around an hour.

Something I noticed about SmartWare is that it is doing something that causes the load on the My Cloud device to spike.  The more SmartWare interfaces I have open (on multiple machines), the worse it gets.  This is what I saw earlier tonight with 4 machines trying to process backup jobs with the SmartWare interface open:

WDMyCloud:~# top
top - 21:04:44 up 4:03, 1 user, load average: 123.72, 126.63, 93.44
Tasks: 192 total, 2 running, 190 sleeping, 0 stopped, 0 zombie
%Cpu(s): 0.1 us, 20.5 sy, 0.0 ni, 0.0 id, 75.0 wa, 0.0 hi, 4.4 si, 0.0 st
KiB Mem: 232448 total, 186880 used, 45568 free, 2432 buffers
KiB Swap: 500672 total, 177728 used, 322944 free, 1280 cached

I’ve never seen a triple digit load.  Ever.  Going back nearly a quarter century.  It got a bit higher, then the web interface died and the load dropped back to single digits.  I still had SSH and SMB access to the My Cloud device but no access thru the browser.  I have no idea what the web interface has to do with the SmartWare backup process.  The backup process still seemed to be running without the web interface.

The load also spikes any time I use the web interface thru the browser.  This leads me to suspect there’s a problem with the apache implementation on the MyCloud device.  But that doesn’t explain why the backup software is hitting the web service in the first place.

Another thing I’ve noticed is that SmartWare seems to have 3 gears.  Sometimes it’ll go hella-slow.  Sometimes it’ll move around 5-10 gigs per hour.  Rarely, it’ll move data around 60-70 MB/s.  60-70 MB/s is pretty darn good.  That’s about as fast as I’d expect to be able to copy data to a single hard drive over my gigabit network.

This is all running SmartWare 2.4.6 (updated just after I bought the MyCloud device and started this process) and the latest firmware on the MyCloud device.  The MyCloud device updated immediately when I fired it up and two more times since then. The current version is  -  waiting for the web interface to load.  Just opening the browser kicked the load up to 23.  -  The current firmware version is…v04.01.02-417.  The previous version was v04.01.01-413.  Before that it was v04.something and it came out of the box with v03.something.  I didn’t make note of the specific versions during the initial update.  I just noticed it went from a major release of “3” to “4”.

After watching SmartWare struggle, I decided to try a third party backup solution.  I shouldn’t have to pay additional money to make backups work when I was sold a backup solution but I was curious to see if different software would have the same problem.  After installing the software and selecting a folder on the MyCloud device as the target, I clicked “start backup”.  It scanned my drive and started moving data.  It’s holding around 30 MB/s give or take a little.  Estimated time to completion is about 16 hours.  Load on the MyCloud device holding between 6 and 8.  Which is still pretty darn high but at least it can function.

When I accessed the web interface to get the current firmware version, the load spiked to the low 20s and the backup speed dropped like a stone.  As soon as I got the firmware version and closed the browswer window, the load started falling and my data transfer speed picked back up.

So it seems like there are two problems:

  1. The web service on the MyCloud device is slamming the device’s processor.  When it pushes the load too high, data transfers slow dramatically.  Access of the device though the web interface can be sufficient to cause this to happen.

  2. SmartWare is accessing the web interface on the MyCloud device for no obvious reason.  SmartWare’s access of the web interface causes the load to spike and the data throughput to drop.

While I’ve been typing and editing this post, the third party software has backed up 4% of my 1.2tb data set.

Edited to add: I suppose the root problem could be the applications called to provide data to the web interface.

Following up to my post, the third party backup software finished the initial backup of my 1.2tb volume (1tb after compression) in about 12 hours.

Out of curiosity, I’m going to try to use SmartWare to back up the same volume to a USB3 drive to see if I can tell how much of the slowness is due to SmartWare and how much is do to MyCloud.

SmartWare worked pretty well, for a while, backing up to a USB3 drive.  It was on track to finish in about 20 hours or so before it hit a wall.  It did its first pass backing up all the small files, then chugged thru the big files from the “Not Backed Up” pile, but now it’s stuck with 51.3 gigs still “excluded” and it’s very, very, very slowly adding 1 file at a time to the backup set.

So I conclude that the MyCloud device has a problem with either its implementation of apache or the programs that apache calls to gather its data.  Smartware accesses the web services on the MyCloud device often enough to cause the load on the device to climb so high that it can’t move data efficiently.  And there’s a problem in the SmartWare software that prevents it from completing an initial backup in a reasonable amount of time.

All in all, a pretty sad showing.

I got a WD My Passport Ultra 2TB. The WD SmartWare that came with it slows down my Win 7 32 bit quiet a lot. Switching windows takes 2 mins. Click on something… it takes 30-45 second response time. Once you STOP smartware, all things are back to normal. Am I missing something?

Has anyone found a solution?

Hi,  Liked the idea of MyCloud Mirror 8T and brought 4 of them

thinking 2 for small business (1 at work, 1 off site, swop and update offsite one once a week at least)

same for home

Home one seems ok

Work one, tried initally with 4 computers mixed lot, XP, Windows 7, Windows Vista and Windows 8.1

Windows 8.1 machine is critical, CAD files etc

Installed the unit on the Older machines first as a trial - seemed to work, slowly added other users which seemed fine.

On Windows 8 machine added it and it worked VERY slowly - we are talking a month or more 24 hours a day.

Contacted support and they suggested moving the Mycloud and connecting directly to computer W8 and backing that up only.

Using Smartware since before 18 Feb 2015 the smartware has been backing up almost continually till yesterday 8 May 2015

it has 1.1 TB backed up, 77.2 GB 16,671,075 files 905.36 GB of the files have been backed up

It never seems to get much quicker.  It isnt the hardware thats slow.

Seems like its always playing catchup and there is no one way to bulk save an initial lot of files

I think I have finally given up on smartware, fine for home computers with lots of photos (no many files)

Love the MyCloud - Smartware interface is nice and useable, would like to see how I can improve the speed - it never seems to get close to finishing

Note: I have Norton 360 installed, tried backing up with external hard drives with this, ran for 12-13 hours then would stop for no reason unfinished - did this for several years then stopped

I use File History but dont have any confidence as it seems to fast - used this with a separate hard disk

Got the MyCloud as this seemed a more reliable solution.

When it writes files its fast, just need to get more info back to user about whats happening.

Now looking around to see if I can get another RELIABLE backup solution - happy to pay a reasonable amount IF something works

Smartware is VERY slow.  Installed latest version 2.4.10.  Based on backup speeds, it will take about 1 month to complete a backup of a single PC.

Windows 7 Home Premium


I tried direct wire connect and Wifi, backup speed is the same.  Getting data rate of 0.17mb per seciond! 

Any updates from WD on this?

WD tech support advised me to delete WD Smartware from my machine and install WD Backup. She said that doing so solves a lot of problems that people have like the one’s mentioned by you and others.

She also said that the problem is caused by WD Smartware and Microsoft .Net compatability issues.

WD Backup contains a simplistic interface compared to Smartware, and it doesn’t offer continuous backup.

I’ve used it for several days. It perfomed the initial backup relatively smoothly. The hourly backups take ten minutes to prepare and backup 3.4 GB of data. That seems slow to me.

PC Mag likes ShadowProtect. They’ve given it the top rating in its category for several years running.

Thanks to jtown for the thorough and helpful information (in contrast to the Moderator replies which are uniformly unhelpful).

It seems clear from this and numerous other posts that WD SmartWare is uselessly slow.

Please mention the third-party backup software that is giving you success.

I have an 8TB EX2 and no matter what I have tried I cannot get WD smartware to provide a speedy back up on my Windows 10 machine.  Backup speed is well below 1 mb/sec and at times stops for days.  I read reviews of several freeware programs and selected AOMEI Backupper. My first back up was a system image of approximately 285 MB which took well under an hour. Checking the integerity of the image to restore took about 15 hours. Very simple interface and currently it is backing up 500 GB from 3 disks to my EX2 at ~50MB/s with an estimated finish time of under an hour.   Clearly the problem is WD Smartware and that is very disappointing.  

Just a quick 

Me Too on this. 

Never seen such slow backup.

My laptop (Windows 10 x64, Hybrid drive, i5 processor, 6GB ram) has almost no disk activity and Network throughput is intermitant (I normaly achieve a steady 65Mbps when copying to other drives) here its like its sending one packet at a time.

Wired Gigabit connection to a 4TB MyCloud, with Gigabit switch/router. No other powered on devices on network.

File copy is faster!

Baught this to back up my network prior to a house move. at current rate it will not finish till 3 weeks after the move!

please sugest other backup software.

i know its an old thread… but since there is no solution here, here’s what i did to get around this problem that i am facing even now.

  • Backed up all the files (700GB) using WD Backup to a mapped drive of EX2. for example Z:\ (6 hours)
  • Initiated continuous backup to that same drive and disabled it. This created SmartWare.swstor folder in Z:
  • deleted files in there that were backed up by SmartWare
  • moved backed up files from step 1 to Z:\WD SmartWare.swstor<yourpcname>\Volume.nnnnn.nnnnn\ (created by SmartWare)
  • Enabled conitnuous backup in SmartWare
  • Backup verifies the currency of the existing files (1Hour+)
  • I made sure i was not editing any files during this period

First, I am wondering if anyone from WD read these forms? There seems to be a major problem in using WD external hard drives to back up data. I have never heard of anyone who thinks WD software works appropriately for this task. As this was my main reason for buying this hard drive I am highly disappointed. Can someone from WD please take the time to help all of us with these issues? I have spent endless hours backing up and reading these forms and am growing tired of it.