My Cloud Mirror Review

Continuing the discussion from My Cloud Mirror Review:

I also would like to provide some feedback for people who are planning to purchase a WD MyCloud Mirror NAS.

I had the unfortunate experience of having my main hard drive fail in such a way that I had to have a drive recovery company recover my data. The head mechanism failed so they had to take it apart, reinstall heads, calibrate and then recover as much data as possible. I got back 100% of my data but cost me $2300. I normally manually backed up my data to USB drive and placed that drive in my safe. However that only helps if you do it often. It had been 3 months since my backup and in that time there was a large batch of data that I really needed so I was willing to pay for it.

I was very excited to take a major step towards ensuring my precious data is protected and not risk another large bill of worst yet, total loss of critical data. My plan was to have continual back up my computer to the NAS mirror with the redundancy of the two mirrored drives and then monthly backup the NAS to a USB drive and place it in my fireproof safe.

I purchased a 8TB MyCloud Mirror and used it in Raid 1 mode. I then planned to use my 4 TB USB drive to dump the MyCloud data to monthly and place it in my safe as a hedge against a disaster.

I created 5 Shares. Videos, Music, Pictures, UserData, and OpSysImage. The total of all data sets was about 1 TB.

First I had troubles with backup speed via LAN from my desktop computer to the WD NAS. Also the Smartware seemed very brittle and if you did anything too complex it would slow to a crawl and never finish the backups. I contacted support multiple times and got some help but this took hours and hours of time and many complete restarts from the very beginning. Here are some suggestions for initial backup to the WD Mirror.

I found that the Windows Service called Volume Shadow Copy had to be enabled and set to Automatic. (Control Panel – Administrative Tools – Services)
Scroll down list of services to Volune Shadow Copy abd double click to open contro box
Set to Automatic and then Start the service.

This seemed to fix one of many issues I originally had with getting a clean backup.

Other issues are backing up directories that have a huge number of files. Clip art has a huge number of files. Also some of the App data / Local for some applications like Mozilla have a huge number of files. It seems like Smartware chokes on a huge number of small files.

Last thing is make sure you are not backing up a directory that has a lot of files that are in use like system files etc. Once Smartware has a big list of files it can’t back up, it goes back and retries very often and ties up the backup.

Once I had a complete backup on the WD Mirror, the Smartware SW seemed to do a good job of backing up each share on the schedule that I set up (once each hour).

Next I wanted to backup to my USB drive. So, with the USB Backup, I expected it to go very logically and easily. I created a Backup job using the MyCloud Mirror Dashboard. I selected each of the shares to be backed up to my USB drive. I plugged in the USB drive and made sure that it was recognized by the backup job.

I started the backup job and came back a couple of hours later and the completion bar showed a little tiny progress. I tried to look at one of the other shares but the dashboard became completely unresponsive. It appears that the backup job was completely consuming the CPU and LAN communication process couldn’t do anything. It was almost like what happens if you have a hardware interrupt line shorted to ground and the processor is in an endless loop answering the interrupt so no other process can run.

I decided to let it run for 24 hours and then see if the backup might complete and release the processor. However even after 36 hours it was still totally unresponsive to any outside communication from Smartware, Web Browser or from the WD Cloud. I decided to do a reset from the rear panel however even that wouldn’t work. Whatever was going on, the processor wouldn’t even allow a hard reset? Finally I had to simply unplug the power. I then unplugged the USB drive after the power was off.

After the WD Cloud Mirror powered up and checked it’s drives for errors due to a power failure, I can now access the dashboard normally and Smartware accesses normally as well. Using the windows file browser I determined that all the shares were intact and undamaged.

I plugged my 4TB Seagate Backup Plus into my computer and it indicated that there was a problem with this drive and asked if I wanted to Sacn it and Fix it. I asked it to Scan and report problems and allow me to choose what to do with each file. The system scanned the drive and found not problems. So I then opened the drive to examine what the backup had placed on the USB drive.

There were two directories in the backup. The OpSysImages (110GB) were backed up and the pictures had backed up about 70 GB of files.

The problems I see that almost make this unusable are:

  1. The WD SmartWare seems very brittle and it is very easy to create a situation that will take weeks to back up your data. If there are services that Smartware requires to be available in Windows, then either it should activate them or at the very least indicate that they need to be set up. There should also be guidance on what things will cause a backup to go astray and slow the process to a standstill.

  2. The USB backup to an external drive it totally unusable unless you only plan on backing up a few mega bytes of data. I found that it transfers at a rate of only 1.8 to 2.0 MB per second which makes the job of backing up a TB of data a 140 hour (5.8 days) process.

  3. As soon as the backup job is launched, the LAN interface as well as the SmartWare interface freeze up almost completely. You can’t get control to stop the backup or look at the progress. In addition even the hard reset (button hole in rear panel) does not respond. Every method of input is completely ignored. The only way to recover control is to yank the power cord and then disconnect the USB drive while the power is off.

  4. The entire time it is backing up to the USB drive, any scheduled backup is ignored and Smartware backup keeps reporting that it is unable to backup due to loss of communication to the My Cloud Mirror.

The advertising and the data sheet indicates you can do a USB backup using the USB 3.0 Expansion ports. USB 2.0 would give 20 to 40 MB per second and USB 3.0 would be 10 times faster than that.

I really wanted this to work and I tried really hard to get it to satisfy my needs but at this point I am almost defeated and ready to get something that works correctly even if it costs a lot more.

I was very enthusiastic in the beginning of the whole concept. But very quickly found out that all additional software and functions is not professional grade - just plain crapp. I have stopped using them and now use the MyCloudMirror only as a file server no more, no less. I accepted that and now use the SSHD commands line to backup to external drive. Blazing fast.

“only as a file server no more, no less”
To my surprise even that broke with the new Firmware upgrade, so I downgraded to get me going again. (See earlier post on SAMBA panics)

I am seriously considering to rip out my WD drives and buy a Synology frame and populate that with my drives. Currently studying the communities from Synology to see if it is really that good as they say.

The disks of WD are good quality, but their software just looks like a hobby project from some intern to me - bad engineering with ditto support.