Backup MyCloud Mirror to USB Drive freezes WD MyCloud Mirror

When I tried to do a backup to a USB drive, the WD Mirror appears to be unresponsive. The drive lights are flashing with lots of activity but I am unable to communicate in any way. Also the reset button on the back will not work either.

Has anyone else had the MyCloud Mirror freeze up when doing a backup to a USB drive?

I have had a number of issues with the MyCloud Mirror in trying to set up what I consider a pretty simple task. I have a Desktop computer with a LAN connection through a gigabit speed router to the WD Cloud Mirror. I have 32 GB of music files, 225 GB of pictures, 550 GB of Video files and about 40 GB of various other user data files. My intention was to backup each of the types of data it separate shares names MusciFiles, VideoFiles, PictureFiles and UserDataFiles. I also created a Share called OpSysImages where I create and then save images of the opsystem created using Reflect software.

As a final good practice I planned to back up the WD Cloud on a 4 TB USB drive periodically and place that in my fireproof safe.

First I had troubles with backup speed via LAN from my desktop computer to the WD NAS. Also the Smartware seemed very brittle and if you did anything too complex it would slow to a crawl and never finish the backups. At the end of this entry I’ll indicate what I found out to resolve these issues

So, with the USB Backup, I expected it to go very logically and easily. I created a Backup job using the MyCloud Mirror Dashboard. I selected each of the shares to be backed up to my USB drive. I plugged in the USB drive and made sure that it was recognized by the backup job.

I started the backup job and came back a couple of hours later and the completion bar showed a little tiny progress. I tried to look at one of the other shares but the dashboard became completely unresponsive. It appears that the backup job was completely consuming the CPU and LAN communication process couldn’t do anything. It was almost like what happens if you have a hardware interrupt line shorted to ground and the processor is in an endless loop answering the interrupt so no other process can run.

I decided to let it run for 24 hours and then see if the backup might complete and release the processor. However even after 36 hours it was still totally unresponsive to any outside communication from Smartware, Web Browser or from the WD Cloud. I decided to do a reset from the rear panel however even that wouldn’t work. Whatever was going on, the processor wouldn’t even allow a hard reset? Finally I had to simply unplug the power. I then unplugged the USB drive after the power was off.

After the WD Cloud Mirror powered up and checked it’s drives for errors due to a power failure, I can now access the dashboard normally and Smartware accesses normally as well. Using the windows file browser I determined that all the shares were intact and undamaged.

I plugged my 4TB Seagate Backup Plus into my computer and it indicated that there was a problem with this drive and asked if I wanted to Sacn it and Fix it. I asked it to Scan and report problems and allow me to choose what to do with each file. The system scanned the drive and found not problems. So I then opened the drive to examine what the backup had placed on the USB drive.

I was surprised to find the Backup directory and inside I found 116 GB “OpSystemBackup” directory which was complete and a “PicturesFiles” directory with 79.6GB and 13,500 files. The Picture directory should have been 226GB and 27,000 files. The rest of the backup for Videos and Music showed no evidence.

Has anyone else had the MyCloud Mirror freeze up when doing a backup to a USB drive?
So now I don’t know if everything was preceeding very slowly or if the backup process had frozen up.

WHAT I FOUND TO FIX THE SLOW TRANSFER RATE TO THE MyCloud Mirror -------------------------

I found that the Windows Service called Volume Shadow Copy had to be enabled and set to Automatic.

Control Panel – Administrative Tools – Services

Scroll down list of services to Volune Shadow Copy abd double click to open contro box

Set to Automatic and then Start the service.

This seemed to fix one of many issues I originally had with getting a clean backup.

Other issues are backing up directories that have a huge number of files. Clip art has a huge number of files. Also some of the App data / Local for some applications like Mozilla have a huge number of files. It seems like Smartware chokes on a huge number of small files.

Last thing is make sure you are not backing up a directory that has a lot of files that are in use like system files etc. Once Smartware has a big list of files it can’t back up, it goes back and retries very often and ties up the backup.

Hope some of this helps.


1 Like

Thanks for sharing your experience with the community.

Hope this helps other users.

I just connected a USB drive to MCM this morning and right away I noticed the dashboard was not responsive and would drop connection from time to time. I didn’t even set it up to doany backup or anything. Just connected the drive and the MCM became extremely slow. Once I disconnect the USB drive, my MCM came back to live again.

I was wondering if anyone experienced the same thing and then I see this post.

It depends what services you have running and the size and content of the USB drive.

I’d suspect that the MCM may be scanning and cataloging the content of the USB drive for things like the DLNA server. Doing that is quite processor-intensive, so whilst it’s happening the MCM can become sluggish and unresponsive.

As ever the best advice is to disable any services on the MCM that you don’t need, to optimise performance of the poor little processor inside.

Hi I see the same behaviour,

I have recently purchased a My Cloud Mirror 8TB - 2nd GEN, and can not backup from NAS to USB. I have not been able to backup a folder no progress bar is visible - only a “waiting bar”, and after a while it says “Backup Failed”. The backup folder in the USB hard drive was created, and it contains the root folder of my data, but no files or folder in it.

My USB is My Passport 3TB (actually i bought two - one fails any test and will be returned, when I can get through to Customer Service)

My firmware version is 2.10-310. According to an earlier post, this should have resolved the problem, but not in my case.

i have rebooted Mac’s, changed cables and reinstall…and cannot come across more than can be a variable in the set-up.

I am desperate for a solution please, as it is critical to be able to make a backup of the data that can be stored off-site.


If it stayed that way for couple hours then yes, it might be indexing or something. But it was almost a day and I didn’t see any blinking led on my USB drive so I know it wasn’t being accessed.

I face the same problem with my My Cloud Mirror Gen 2. Every time when I plug the external drive (with some data inside already/ blank drive has no problem) into it to backup the data, the unit crashes and does not respond at all - even with the rest button. Hope anyone has a solution to fix this issue?

1 Like

Same thing happening to me now, no solution found after searching for a month!

I actually believe it has to do with the Backup Software I tried to run once and never completed - I unmounted the USB drive and forgot about it - since then the drive has been so unstable that even with 40 sec restore it still doesn’t respond. The software platform is not equal to the Synology brand, and that is the only reason I’m jumping ship after 15 years.