WD ShareSpace Firmware Update - Version 2.2.91 (12/13/10)

WD is happy to announce the latest firmware update for WD ShareSpace. For information about the firmware update, please check out the release notes.

does this release include the 2.2.9 patch?

Although I haven’t installed the update yet (why fix what’s only half broken) based on the release notes I have to say I’m throughly underwhelmed.

may ask for fix ups status Unknown fix?

Yes! Yes! the ups interface is working again!

Bill, is this supposed to reconcile the advertised throughput vs actual throughput discrepancy that so many of us are seeing?

HAPPY!!! Thanks for the fix guys, I was wondering what I was possibly doing wrong.  :smileyvery-happy:

Hate premature excitement… :angry:  Didn’t fix slow performance issue, and the 2.2.9 patch is listed as stricktly for 2.2.9 and presumably I can’t even use that now…

That “patch” wasn’t really a patch, all it did was:

change “server signing = yes” to “server signing = no” in “/etc/samba/smb.conf”

Turn on ssh access, login and do it yourself.

1 Like

Thanks, quite the adventure, used tools and commands I havn’t used for 10 years.  But server signing already was = no. *sigh*

@ Puppetx

Honestly, I don’t know.  But I’ll look into it.

@bill_s

Thank you very much for your attention on this matter. I appreciate your time and response.

I want to make it clear that despite only being able to get ~1/3 of the advertised bandwidth out of this NAS device I am still quite satisfied with it. Small form factor, consumer level pricing, RAID redundancy, ample storage, and Linux under the hood all but make up for the low throughput.

I’ve since installed the update and done some preliminary testing, I seem to be getting the following bandwidth while uploading files to the NAS: ~10MB/s average

Meanwhile I am able to get 60-70MB/s between 2 machines on the same network, GigE (cat6).

Considering what I’m using this device for the upload throughput isn’t that big of a deal, I can be patient.

What _is_ a big deal to me is that your marketing materials suggested that I should be able to achieve approximately three times the throughput I’m seeing. The feeling of being mislead(at best) sours an otherwise decent product.

Well I’m glad your happy, but iI’m not !  With the latest firmware update I am having to move all my data to another set of drives - this is taking forever, then on top of that I find some files have been locked & I only have read access and worse some no access, If I try and take ownership windows reports user linux/509 need to give permission or something.  Strange as it was me who put the files there in the first place.

Next will be a factory restore and possible RMA or rip the drives and stick them in a QNAP - I have had enough of this device.

Aaaaahhh, when are you going to finally release a link to the .img file for manual update.

It’s already a pity to see that the update software cannot pass through authentication proxy, but in addition to that, manual updates are not available.

tl;dr Post link to manual update please, proxy here.

UPS interface is working for me too. nice to know my sharespace should shut down gracefully again.

Could you send me a download link to do a manual upgrade.

Here you are: [deleted]

In my case after “sucessfull” update I got segmentation error & loss of data shares, which forced me to make Restore to Factory Default procedure.:angry:

Good luck!

Cant seam to upgrade from 2.2.9

The firmware image is not valid. Please use a valid firmware image.

Any ideas ?
Many Thanks

Craig

Just tried the manual update and getting the following error…

The filename of the firmware image contains invalid characters.
(PS have tried changing the file name)Many Thanks

Craig

HI I had the same problems just change the dashes to dots (.) as shown and this worked on my Sharespace

Example : 

From: wda4nc40000-02-02-91.img

To (Correct): wda4nc40000-02.02.91.img

Hope this helps and mine was the 2TB version , but let it complete is process even when it states it is rebooting this can take up to 20 mins , But you must leave it to complete , Also restart your PC after this update so that everything is refreshed.

Hope this works for You … all the best  Neil