WD Ses USB Device Not Found!

Good Day

i have i 1Tb hard disc i used it almost 1 year and suddenly its not working, my computer cannot read it anymore. i tried to find whats the problem and its written WD Ses USB Device not found i tried to update it but it always failed. and then and do some research i found this website and then i read some articles same problems with me and do all the instructions but still not working for me, why is it??? i tried another computers also but still same… i have important files on it i think all of it is important how can i access this file??? i dont want to reformat it bcoz it will erase all my data… please please please do help me im very desperate…

thank you

nobody can help me???:cry:

i have 32 viewers but nobody can help??? i can think properly this day because of this haaayy

Hello, check if the hard drive is still recognized on the disk management window you can also try using another US cable. What model do you have exactly?


my passport 1TB the silver one… i check it on the disk management, written disk2-not initialized i tried to initialized it but always error and tried to use other USB cable but same result… whats the other solution for this, is there a way i can use my drive without the SES drive or the only solution is to reformatting but i have important file on it…

thank your reply i really appreciate it.