Problem: WD Ses USB Device - No Driver Found

Hi all,

I am unable to access the data on my 1TB WD MyPassport external USB3.0 hard drive (P/N WDBACX0010BBK).

I have tried connecting the device to other computers and laptops as well as connecting using other compatible USB cable. 

Below are the problems:

 1. When I connect the device to the computer, it says “WD Ses USB Device No driver found”.

 2. Installation of WD Ses Driver failed.

Problem persists even after installing the WD Ses Driver from the official url below:

 3. Update Ses Driver via Device Manager failed.

Under device manager, I tried updating the WD Ses Driver and received a message stating that the driver software was not found. 



Please help!

Welcome to the Community.

Have you tried a USB 2.0 cable instead of a USB 3.0 cable? This can force the drive’s controller to behave differently.

Hi Trancer,

I have not tried connecting via USB 2.0 cable. 

The cable that I am using right now is Standard USB3.0 Type A Male to USB3.0 Micro B Male Cable   as shown below:

Tried searching for USB 2.0  compatible cable, but to no avail. 

I wonder if there is any other way to force the driver’s controller to behave differently.

That USB 2.0 cable is the correct one. Notice the shape; it will fit into the “flat” portion of the USB 3.0 connector.


I’m having the exact same issue for P/N WDBACX7500ABK device.  I have 2 devices and one works (PN WDBBEP0010BBK).  I have try to chance the cabels to identify is this related to cabel isse.  I have installed several time the SES drivers.  No luck.  Can you let me know did you get a chance to resolve the issue?




I’m having the same issue as well. Did either of you ever figure out a solution?


Did anyone ever figure this out? I’m not very techy and am struggling.

Go here: Software and Firmware Downloads | WD Support
Choose x64 (windows 10 x64, windows 7 x64) to download the driver zip file
go to your downloads, right click the zip file and extract all
next, next until finished

Go back to downloads folder
open the unzipped folder called WD_SES_Driver_Setup_x64
double click to install WD SES Driver Setup (x64)

1 Like

I’m pretty sure people still would find this relevant in 2023. I just bought a 2TB WD My Passport. It showed up in My Computer in Win7 but Device Manager says not properly installed (!). A quick search led me to this page but when I followed the link to WD Support it was no longer there. Digging somewhat brought me to the right page below.