Wd ses device usb device The drivers for this device are not installed. (Code 28) window 11

I am on Windows 11, upgraded from Windows 10. I have a WD My Book 4TB 25EE USB drive. It appears to be working just fine.

I have WD Drive Utilities and Dashboard installed and they both appear to be working fine?

I don’t know why I am getting the subject error in Device Manager?

Tried UPDATING the driver, can’t be found either on my PC or via MS Update.

I see one can D/L the driver from this site, but it is from 2011?

I did an UNINSTALL of the driver in DEVICE MANAGER but it always comes back?

When on W10, I don’t recall this showing as an error?

When I read about the driver, it seems to be for a portable external drive, not the power My Book’s?

Is this needed or a Windows 11 compatibility problem?

Again, the disk appears to be working just fine?

1 Like

Hi @Irv_S,

Western Digital is in the process of validating compatibility for Western Digital solutions with Windows 11.

For more information, please contact the WD Technical Support team for best assistance and troubleshooting:

I just bought a my passport 4TB and mine is doing the same thing

Hi @Keerti_01 you mentioned that WD is in the process of validating compatibility for Western Digital solutions with Windows.

That was mentioned 3 months ago. Is there any progress? I’m still seeing the “The drivers for this device are not installed. (Code 28)” in regards to “WD SES Device USB Device” for both of my Easystore 18 TB drives running on Windows 11.

I’d like to understand how long do you think it will be before this driver is available?

Thanks in advance.


I recently upgraded to a new Windows 11 desktop, getting same ! notification in Device Manager.

Has there been any news on this? I’m getting the same message.

It’s now October 2022, and I have the same error in Device Manager on Windows 11, but the WD My Book Duo is working perfectly. There are still no updated drivers available.

To get the drivers updated. Go into Settings > Windows Update > Advanced Options > Optional Updates > Select the Western Digital drivers.

This worked for me today, 2022.10.17.

Hi Guys!

Had the same problem here Win 11. Installed WD Drive Utilities. Worked out for me!

It’s been a long wait, but evidently the folks at Western Digital have corrected this.

I found the same error on my Settings screen, under the Other Devices. There sat the My Passport drive with a little yellow warning triangle. Tried the same things y’all did. None of it worked.

I opted to go to the Western Digital Support pages (official website) to see what I could download. Go here:

Choose the WD Drive Utilities, let it download, run the installer, and – BAM! – the annoying Error Message is no longer present. Simple fix, if you’re a bit OCD about this stuff. PLUS… you get to have some nifty HDD Management Tools to streamline the use of your My Passport drive!

There ya go…!
[ mic drop ]

~ Sam Westhoek

1 Like

I can confirm that this still works. Windows Update > Advanced options > Optional updates, then check the box for Western Digital Technologies.

1 Like

I can confirm that as of this date (17 Aug 2023) this solution is still valid.