WD provides no support for attached MyBook crashing MyCloud

I purchased a MyBook and MyCloud from Best Buy which had no RAID drive at the time of my purchase. The expectation was to run TimeMachine from my Mac and use Safepoints to replicate MyCloud on the MyBook. This would seem to be a very common set-up, and is even described in the WD documentation. So WHY DOES THIS NOT WORK? Multiple threads on this site explain work arounds. Google hits show this to be a known problem for well over a year. Having worked in the software industry for 25+ years, I cannot understand how this problem could get through even minimal product testing without a fix. Furthermore, WD support responds as if they’ve never heard of the issue and provides absolutely no help except a (useless) hardware RMA (I’m on my 3rd MyCloud now–neither RMA worked at all when received and needed factory reset and new firmware to run).

My entire experience with WD make me think I’ve entered the world of Dilbert as a hapless customer.

I am posting this note in the hope that someone at WD reads these posts and is embarrassed enough to ask engineering to fix it. I cannot for the life of me understand how these devices get high ratings by PC Magazine and the like unless there’s payola involved.

So sad. So disappointing. And no way to get my money back at this point.

Why are you unable to perform the backup you have in mind? Do you get a particular error message? What have you tried so far? What are the specifications of your router? Where is the USB My Book connected to? Are you using a hard-wired connection?

set-up is:
MacBook …wireless … MyCloud ---- USB — MyBook.
±-- Time Machine ------+ ±-----Safepoint ----+

MyCloud plugged into ethernet of wireless router, Cradlepoint MBR1200. Time Machine backup over wireless connection (runs about 3-4 hours for full initial backup). Safepoint is set-up using MyCloud Web dashboard. MyBook is ok – it’s possible to use ssh and tar or rsync to copy files from MyCloud to MyBook.

Per multiple posts on this site, disconnecting MyBook allows time machine to run fine. Attach the MyBook and within a few minutes the MyBook becomes “invisible” to the Mac. Browser access fails. SSH access shows the Apache servers are not running. Reboot command, from ssh will typically fail, and only power cycling the MyCLoud permits a reboot. If the MyBook is still attached, the MyCloud will typically never become ready, i.e., other than SSH no other app/protocol can connect - no browser, no Mac "Connect to Server (afp or smb), no Time Machine.

The failure is so utter and complete and so easily reproducible and so frequently reported, the problem can only be attributed to WD testing incompetence not to have encountered it. And as previously stated, for Support to act as if they never heard of the problem speaks volumes as to their lack of training–just search this topic on this site to see how often it has occurred for others.

I am still trying to determine which of the proposed work arounds might resolve my issue. Here are a few links.

I just checked your router’s specifications. It uses 10/100 Ethernet ports, which is not ideal for what you are trying to accomplish. Physical (Hardware) bottlenecks lead to latency, which affects performance and can at times result in a network dropout.

Agree, anyone using a NAS device should have upgraded to a gigabit router by now. I get speeds of 113 MB/sec on file transfers with all systems “go” (meaning gigabit through out, including any network switches and USB3 drives using my DL2100 NAS.

I don’t wish to be rude, but the point you raise is irrelevant. The transport prototcol will handle whatever link speed it sees. If there’s a network drop at slow speed, that is a design or implementation bug. Moreover, my access to the drive wireless, which is at best in my case about 30Mbit or so. And of course, the problem does not occur with the MyCloud alone, only when the USB drive is attached.

Yup… this post is absolutely true!! at least a half dozen users have already experienced it and I on the latest OS 3; this problem has not been fixed and probably will remain unfixed for a long time yet.

Don’t forget my post…

Absolutely terrible! Absolutely Unusable!

This USB My Book crashing was the first problem that I encountered in January of 2014 in which I ranted my first post on this forum. At that time I was trying to move my new cloud over to the bookshelf via a 50 foot ethernet cable. The unit would disappear after a few minutes due to the usb lock.

The problem occurs when you plug in a USB drive that is full of files that has not been media scanned previously. Theoretically it does not happen if you load up (i.e. copy files to) the attached USB MyBook through the Cloud.

There are two work-arounds. The first workaround, I’m not too sure if it would work but you can definitely try.

  1. wait a good 5 minutes after the cloud has booted up before plugging in the USB drive
  2. when you do plug in the usb drive, make sure you turn off media server on the share. This will stop the scanning.

if the above does not work… then the following is guaranteed to work as it has been my work-around for the last 2 years.

You need to ssh into the cloud and stop the scans

etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop
/etc/init.d/wdnotifierd stop
/etc/init.d/wddispatcherd stop

The last two wdnotifiered and wddispatcherd are the culprits to the dead lock that occurs when attaching a USB drive.

After issuing the above stops…

attach your USB

then issue
/etc/init.d/wdnotifierd start
/etc/init.d/wddispatcherd start

watch your dashboard for the USB attachment. Once your USB drive has attached…
issue the following commands again

/etc/init.d/wdnotifierd stop
/etc/init.d/wddispatcherd stop

You need these two services to enable the dashboard updates. Thus to eject your USB drive, you will need to start up the two services, click on the eject in the dashboard, wait until the eject completes, then stop the two services.

@Trancer, I think it is time for WD to acknowledge this problem as it is probably the second probable cause for network dropout since the cloud locks. The first probably cause for network dropout are the scans. If WD fixes these two problems, the forums will be dead quiet.

1 Like

While awaiting call-back from WD level II support (guess they read this forum), I plugged the MyBook into the MyCloud which had been happily running for a week+ doing regular TimeMachine backups. Absolutely froze within 3-5 minutes. Web UI frozen and I cannot even ssh into the box. So I guess plan #1 above doesn’t work :wink:

PS - ALWAYS ask for Level II to call you back. Otherwise it’s impossible to get through the frontline wall of defense, even if the case log says “please call xxx and ask for level II support”.

It has been 2 years since I’ve worked on it. Back then plan #1 did work but then again I may have stopped and started the two services.

Also with the latest firmware, wddispatcherd is no longer in service, so it is just the wdnotifierd that needs to be stopped, along with the scans.

You will get no answers from WD Level II support other than to RMA your Cloud, which will exhibit the same problem. I have 3 clouds and 3 mybooks so I know that it isn’t a hardware problem with a single cloud. However by giving them your log files it will probably help them solve this mystery someday.

I was hoping that turning off Media serving on the USB drive would solve the problem. You did turn off the media serving switch? right?

@Bill_S @Trancer, please pass this on to your WD CEO to get it fixed. no not the WD Level II support.

You’re right about the Level II response – another RMA. However, this time they are “upgrading” me to a MyCloud Mirror with RAID 1, which of course is what I wanted in the first place but was too impatient to order online. I very much don’t understand their support policy. Companies I’ve worked with really wanted to fix problems like this. Of course those same companies had pretty good product testing and things like this seldom made it past beta. I will post an update in a week or two after the new disk is here and it’s been in operation for few days – hopefully that’s not too optimistic :wink:

Oh wow, the squeaky wheel does get the grease :sunny:
hey!! @Bill_S, @Trancer, I’ve had this problem for 2 years!! where is my MyCloud Mirror with RAID 1?

You know a possible fix for the My Cloud locking up under these conditions. Would be to set the process priority lower than any other processes. That way when ever the wdmcserverd is running
and something else needs the CPU. Wdmcserversd would be put to sleep and the other process would take over the CPU.


of course, I’ve already proposed how to lower the priority in the other thread and we just need some testers :stuck_out_tongue:

Just wanted provide an update on the replacement MyCloudMIrror device. Timemachine has had no problems and access from Finder or the shell behaves as you’d expect. However, as soon as the (same) MyBook is plugged into the USB port, it hangs in the same manor as reported for the other drive. No surprise. Same crappy software still not updated to fix the problem. At least now I don’t care (assuming the WD Raid support actually works).