WD photos does not show photos

I have a 1TB my book live, in the public folders I have all my photos saved, around 30000+

The file structure is generally Shared Pictures> then:

my tablet uploads>

Photos by year>

Phone uploads>

now on my tablet and phone the WD photos app shows the photos from the two upload folders, however none of them show the photos in “photos by year”.

It sometimes lists 2007 folder and its subfolders but none of the other years: screen shot below.

I have carried out the full range of diagnostics on the admin page on my laptop, including:

  • Rebuilding the database
  • Rescanning Twonky
  • Rebuilding Twonky

after switching the remote access on and off each time, I have also uninstalled and reinstalled the apps on both the android tablet and Iphone, I have cleared caches, I have rebooted the drive, I have done essentially everything I can think of.

Ironically when I first got my iphone 3 years ago the app worked perfectly apart from the slow update of added photos, it just stopped working over a year ago and I have tried everything since then.

My previous attempt to sort this out through the forum and PM with WD went done the route of Port forwarding which I couldn’t figure out on my Homehub 4 (as I am not a technical person).

Any help would be greatly appreciated.



Try switching between TwonkyMedia and WD’s DLNA Media Server

Check this link for more information.


Thank you for the link, it does talk about the DNLA server in the same paragraphs as Windows 8 however I am only running WIndows 7.  This will not cause it a problem will it?

I have run the switch as recommended however I still have the same problem.  The folders that are generally closer to the root have populated however the Photos by year has not, it has shown the 2007 folder in it but this is then empty.

When I first installed the app as new years ago it was fine and showed everything so I know it is possible, it however was never good at updating when new photos were added.

I know that the RAW images will not show which is why they are filed in a seperate folder and this will always be Zero, the northernman folder is form my tablet and the pocket rocket is my phone which do not seem to have a problem.  It is the 30000 photos in the “-by year” sub folders that are missing.

HDKnows wrote:


Try switching between TwonkyMedia and WD’s DLNA Media Server


It’s my understanding that WD Photos doesn’t use the DLNA server.


WD Photos uses the pictures that are scanned by the DLNA Media Crawler.

I agree it’s true that

WD Photos uses the pictures that are scanned by the DLNA Media Crawler.

in that both use the same pictures. However I’ve obvseved that WD Photos works even if Twonky is disabled.

Also at least on a My Book LIve with Twonky the images could be in any directory but for WD Photos they can only be in Public\Shared Pictures. And as long as Twonky is running I can see all my photos from my WD TV boxes. Or a DLNA app like Skifta.

But here’s my problem: When I notice that new folders I added to Shared Pictures weren’t appearing in WD Photos I went to the knowledge base and found this

WD Photos does not display all the photos on a Personal Cloud drive or WD NAS drive

So I

Disabled remote access
Rebooted MyBook Live
Enabled remote access

Nothing changed. So I

Rebuild wd2go server

Now I’m much worse off. WD Photos is ONLY showing the one newest directory and its subfolders. It’s stuck on 320 photos and never grows. I have no access to the 5,000 other photos.

I opened a case with WD Support and but the only support I’ve gotten so far is a link to the knowledge base article above.

Isn’t there some way to start all over again. I understand for pictures to appear in WD Photos the My Book LIve has to transcode all the images and that could take a day or two. I can wait. But now I’ve got nothing (almost).

BTW I also tried un-installing and re-installing WD Photos on my phone and tablet.

One more thing. WD My Cloud is also fine, all shared pictures directory are accessable. Albeit slowly.

Of course the advantage of using WD My Photos since it does transcode images to phone size they view quickly.

Please, I could really use some help here.

I had a call logged a year ago with WD and we got as far as setting up port forwarding on the router, however this was beyond my ability and this was as far as we got.

I get the impression that once you have lost the Wd photos ability to show all the photos they don’t know how to get them back. 

On further searching through these forums I find that the “miocrawler” transcoder stopping a fairly common problem that the is a fairly common problem with no resolution.But I aslo found that there are other users that complain that it never stops; the flashing green light on the MBL indicates constant disk drive access.

This does beg the question: Why doesn’t WD provide a web interface to start and stop the photo crawler used by WD Photos? Like there is for Twonky? At least you can easily turn that off if you don’t want or need it.

However you can control the the miocrawler daemon from the command line using ssh:

Usage: /usr/miocrawler/miocrawlerd {start|stop|enable|disable|reset|status}

I found that status showed me that it was not running! So I did reset and a start. It processed the 320 photos in my newest directory and then stopped. So that left me right where I was before. So I deleted that diectory and tried again. It’s now churning away, processed 5000 files since last night.

So I think I’m good to go. When it’s done I’ll copy the new directory back again, and see if I can figure out what it’s problem is.

Thanks for this, i enabled the SSH and opened the SSH command line but I couldnt get it to show me the status or reset the miocrawler.  What exactly do I need to type into the command line to get it to work?

/usr/miocrawler/miocrawlerd status

I’m also having this issue. I have thousands of photos in my “Public” folder and yet the WD Photosapp on both my iPhone and iPad says I have only 1 photo in that folder. I’m using a 3 TB My Cloud. As an aside, ALL of the photos appear in the iPhone/iPad My Cloud app. I’ve deleted and reinstalled the app, rebooted the My Cloud external drive, and even did a rescan, but none of it helped and I’m still not seeing the photos. Anyone have any thoughts?

shh into your server and use the command and reset

/usr/miocrawler/miocrawlerd reset

Then use start and check the status

/usr/miocrawler/miocrawlerd start

/usr/miocrawler/miocrawlerd status

And then check the status again. When it’s no longer running start it again. This works for me… up to a point. Eventually it stops adding new photos, still haven’t figured that out. You can check the log with this command

cat /var/log/miocrawler.log


It would sure be nice if someone from WD would comment on this and perhaps add further explanation. There must be someone there who knows how this is supposed to work.

I go into the SSH putty option and set the miocrawler running and it will run for a maximum of 1 min before showing as stopped.

I am not able to use the photo app at all as it never sorts through all my photos.

A waste of time, and it was such a promising function/app

Take a look at the log; it should tell you why the crawler stopped.