Wd Photo can't access thumbnails on wdmycloud


I can’t see any pictures in Wd Photo Android App, just folders and files, I’ve already tried all WD Support recommandations in knowledge base but still annoyed. thumbnails exist in .wdmc folder and i can read them by a root ssh session. It seems like a right access problem as if wdphoto user could not access to these thumbnails files. Could someone help me please ?

Welcome to the Community.

How long has it been since the files were added? WD Photos does not transcode pictures/thumbnails pictures for display in real time.

1 Like

Thx for answering, well in fact I always knew this problem (with another but linked i suppose : dash on left capacity of the UI) so this Monday I decided to erase all my data by a full restore, the problem was solved of course. After I put a few photos on the Wdmycloud, the database has been built in a minute and I could view my thumbnails in WD Photos Android App.

Next, I copied all my 56000 photos, and 2100 little videos, after that I’ve waited about 12 hours for having “idle” in the “Content Scan” Area of the UI, so for me the “indexing” job was done, so return to the WD Photos App and no way, I only see the first salve of photo copied before.

I’ve cleared the cache in the android app to force re-sync and know the app tell me that there is no photo on the device, i checked the thumbnails by ssh, it seems ok. I’ve got also a wdphotos.db file but it seem empty, well I’m lost.

For now, I’ve done a cold reset after disabling cloud access, re-activate cloud access : always nothing in Wd Photos App. So I launch again a re-rebuild of the content database and I’m waiting the result.

Do you have questions to help you for diagnostic ?

(As you can see I always wait for the end of the database building before rebooting, or doing anything, I’m on that since Monday…)

Did you check if the mediacrawler service related to the media library is running? It affects content transcoding for WD Photos.

1 Like

I have a error in content state area so i will try this :

/etc/init.d/wdmcserverd restart;
/etc/init.d/wdphotodbmergerd restart;
/etc/init.d/wddispatcherd restart;

wddispatcherd don’t exist.

wdphotodbmergerd was stopped it should be the “mediacrawler” service, shoudn’t it ? Whatever I relaunched it and rebuilding content database is going on now ? Why does this service has stopped ? An idea ?

Content database rebuild : Done

 2 db files were created :

WDMyCloud:/DataVolume/shares/.wdmc# l
total 71948
-rw-r–r-- 1 root share 72538112 May 1 08:52 wdmc.db
-rw-r–r-- 1 root share 32768 May 1 09:04 wdmc.db-shm
-rw-r–r-- 1 root share 1094144 May 1 09:04 wdmc.db-wal


WDMyCloud:/DataVolume/shares/.wdphotos# l
total 6240
-rw-r–r-- 1 root     share    5120000 May  1 00:42 wdphotos.db
-rw-rw-rw- 1 www-data www-data 1263589 May  1 09:16 wdphotos.db.dl.gz

When I open WDPhotos Android App (tried on 2 devices), I’ve got now all the photos listed BUT still no thumbnails, no preview, do you have any idea ?

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country