WD Passport for Mac not visible anywhere apart from System Info and WD Discovery App

Hi

When I plug in my WD Passport for Mac it does not appear in Finder or Disk Utility so I can’t mount it through that/run first aid. It is visible in System Info however and the WD Discovery app but when I click mount through the app nothing happens.

In terms of hardware, I’ve tried multiple USB cables and the light on the passport is flashing but still nothing on my MacBook

Thank you

Hi @green2,

Please refer to the article for Windows or macOS Cannot Find My Drive: Windows or macOS Cannot Find My Drive

I’ve tried everything on that link but nothing has worked so far

When you connect an external hard drive on Mac, it will show up on Desktop, Finder, and Disk Utility. But sometimes the external drive won’t appear in any of these places. To fix the issue, you can try the below methods:

  1. Change MacOS settings under Finder preferences
  2. Reset (NVRAM/PRAM/SMC) Mac firmware settings
  3. Fix external hard drive connectivity issue
  4. Mount or Repair the external hard drive using Disk Utility

Further, I suggest you to check the below link for detailed steps to be followed in each method above.

https://www.stellarinfo.com/blog/resolve-external-hard-drive-not-mounting-on-mac/

Hope it helps!