WD MyCloud on iPad 2 - can't stream media

This was working fine last week, but for some reason I can no longer stream video media on the iPad when not on my home network. No problem using my Android phone, but the screen on the iPad is bigger so I’d rather use that :wink: I’m checking media files which have worked in the past (mp4s) and the same files will work fine if I download and play them within MyCloud. However, if I try to stream, the spinny circle appears for about a minute before I get the popup “ERROR - unable to play this media file”. Network speeds are fine - downloads run at 1Mb per second or better so that shouldn’t be an issue. Audio files stream with no issues.

I see this issue every now and then, but I’ve never pinned down the EXACT fix. 

As with any misbehaving app, I’ve run through these steps and usually cleared up the problem:  

Try these steps:

   – Force close all apps and restart WD My Cloud app and try again.

   – Force close all apps, then soft reset the iPad, then retry the video.

   – Force close all apps, then HARD reset, then retry.

Thanks, Tony, but none of those worked :frowning: I also noticed that I’ve got a permanent little red “1” above my activity icon, yet the section is empty when I look at it in detail. I wonder if something has become stuck. I just uninstalled the app and reinstalled it which got rid of the rogue “1” (and the handful of files I’d downloaded, but hey) but still no joy. Pah. Iain