General network error 500 on mycloud ipad app

my 2t personal cloud server seems fine, but attempting to stream music on ipad with mycloud app generates this error message. My photos works fine, and accessing files as files is ok. Using MediaConnect app works fine. I already tried rescanning the media files.

Clues?

Hi there and welcome to the WD community.

Try to see if this happens on a different mobile device to see if you get the same result. I would also like to know the types of media files that give you this error.

Thanks for the reply.

Good thought on another mobile device, but I only have the iPad. The files are a mix of mp3 and mp4’s.

I have the same problem on all devices Ipad, Iphone when trying to access my public folder, same message appears “WDGeneralNetworkError500” . On my Mac & Windows8 machines when trying to access the same folder i just get the spinning circle that never stops.  All othere folders can be accessed on any device. Any idea what to do?

I’m gettting the same  network error on ipad and iphone and on a friends andriod device.

This was workign fine but then since the last update this is all it does, can use the the “all” bit and just browse through all my photos, music moves ect. but it takes for ever and really poor experience when listening to music.

I think it must be the app update as it was working fine before. I’ve rescanned and rebuild like oit says in the trouble shooting but narda-nothing.

when will wd sort it out, every update has issues, really is one step forward 3 back.

So I’ve jsut relsolved this issue i’m having error 500.

I logged on to wd my cloud dashboard via a browser 

went to cloud access and deleted any devices i was having issues with, iphone / ipad in my case.

then on my iphone and ipad opened mycloud app and logged back in and it all worked fine.

let me know if this resolves your issues.

okay so its stop working again, tried teh same steps as above and narda.

the issues started tthis time when I copied some new music over from my laptop to the drive. less then 70mb of files.

now when it try to access music, photos or movies via the app (iphone + ipad) i get error 500

this device is so fradigle its ground for a law suit, its not fit for purpose nor work the way iys advertised…

anyone got any solutions?

IMG_6425.PNG

Just purchased and installed the WD My Cloud today. Nice to have a central NAS but disapointed I am also getting this 500 error right from the start for music, videos and pictures on the iPhone app. Not a great start… If someone found a solution, thanks for sharing.

Just an update: since the WD My Cloud app is not good enough to browse music, videos, etc, I opted for the 8player app on the iPad, which is absolutely great. Even better that the native iPad apps. Tested it with music, videos, photos, etc and it browses, searches, and streams flawlessly on the iPad and Apple TV from the WD DLNA server. This is of course for use with the wifi at home and not a solution for remote access. Finally reached the goal of accessing all media without requiring a laptop to be turned on.