WD myCloud complete data loss!

Dear all,

I was experiencing slowness on accessing my myCloud 3T device from 1 / 2 days so I decided to access the dashboard…
Impossible to do anything on it…stuck on “updating”…
So I decided to do the 4s soft reset … same thing…slowness…
So I decided to do the 40s reset…same thing, stuck on accessing the dashboard.
I tried another 40s reset and it booted properly…after a long time…but this time…without any data !!!

More than 2T of drones video / photos loss !!! How is this possible ?!?!

What to do please? Can i recover something ?

Thank you,
Best Regards,

Hi Pascal31,

Please know that the 4 second or 40 second reset is not data destructive process. Is your data not even showing up in mycloud.com or My Cloud app?

Well, I know but nothing to browse, just the standard 3 directories as it was quick formated or fsck “ed” during a startup…i don’t understand how it is possible…

So here what I started :
-Unmounted the 3TB disk from MyCloud box (no more on warranty…)
-Bought a Sata 3.5’’ USB case
-Use of PhotoRec on png, jpg, bmp, gif files

and it works…waiting for the end : 6 hours of processing to recover my personal pictures. (my priority)

After that, I will try another method based on backup superblock (dumpe2fs, fsck.ext4) to recover the whole file system…nobody seems to do that here (?!?) but it can work and will be better than a single file recovery.

Best regards,

PhotoRec finally failed … stuck/hang at 50% of the disk…:frowning:
I was pretty disapointed so I tried another method…and…

Success !!!

After my crash and a complete data loss, I manage to recover 99% of data.

The secret is the backup superblocks !!!

Here is the recipe :

First, unmount physically your disk from mycloud case…and install it into a 3.5’’ SATA to USB 3 case.
From a linux computer…identify the partition where data were stored :

fdisk -l

should list everything mounted…choose the good device 2.7TB for me was /dev/sdb4

unmount your disk if it was automatically mounted

umount /dev/sdb4

Now identify you backup superblock (previous filesystem description)

mke2fs -n /dev/sdb4
dumpe2fs /dev/sdb4 | grep -i superblock

choose a backup superblock from the list (for me the first one 32768)

then make a checkdisk considering your old fs description in the choosen superblock…for me blocksize were 4096

fsck.ext4 -y -b 32768 -B 4096 /dev/sdb4

Results after 2 hours : Everything is back in a lost+found (GUI hidden) directory !

Hope this help because everything here was too complicated… :wink: :wink: :wink:

Best Regards,