WD My Cloud Home killing Wireless Internet Connectivity


#1

This is brief overview of my setup
I have broadband connected to my router (Tp Link WR841n) and has wireless configured
The router is also connected to Gigabit switch (Tp Link TL-SG-1005D) via LAN (LAN port in router to switch)
I’ve my WD My Cloud Home (3TB) connected to that switch. Also my Xbox and PC

The problem,
Whenever I’m connecting my WD My Cloud, the wireless of my router is getting killed. I can connect devices via wifi but none of the devices are able to access internet (sometimes very very slow). The moment I’m removing the LAN from my WD to Switch, everything seems to work fine.

However, the LAN connection is not affected meaning when everything is connected I can access internet on my PC and Xbox with no issues, just that the devices connected via Wifi are not able to open any webpages.

Please help me in resolving them since I share my home with others and they are not able to access the internet if my WD My Cloud Home is connected

I tried Googling and tried the solutions like QoS (Bandwidth control) but no luck !!
I also have a reserved IP for my WD MCH and hence no IP conflict issues as well

I tried with another router ( DIR-600M ), same issue.

Is it because my routers are having 100 Mbps Ethernet ports and the Switch is Gigabit ?? But again how that would kill Wireless Internet connectivity


#2

@davishekwd sent you a private message requesting information.

Thank You


#3

Hi,

I have a much simpler setup, with exactly the same issue. Whenever the WD MyCloud is plugged directly into the router, all Wi-Fi connectivity is lost, or significantly reduced. I am going from receiving 40mb/s on all wi-fi devices to either zero or no more than 2mp/s. Please could you support me in fixing this.

Thanks,


#4

got same problem here, but i found a solution, the problem is the power supply from the cloud it kills the wlan i put some aluminium foil over the powersupply and voila wlan is back!
this needs an replacement from wd how to get a decent powersuply from you?

MFG


#5

Unplugged Cloud ethernet cable from router. Unplugged power from Cloud. Waited 1 minute. Reconnected ethernet cable to router. Then reconnected power to Cloud. Now working. Could probably just remove power from Cloud for a minute and have same result.


#6

Hi all,

Same problem here.
Already tried every single option i found online and none worked.

  1. alumminium foil arround the charger
  2. disconnect and reconnect,
  3. changed ethernet cable,
  4. changed ethernet port in my router,
  5. reset mycloud home
  6. disconected all automatic backups…

Anyone solved the problem??

I’m about to return my cloud since i didnt find any solution :frowning:


#7

Has anyone managed to solve this problem? The same is happening with my Mycloud home


#8

why nobody from wd can answer here? this is a common problem with my cloud home!
this really pissing me off always need to reboot the cloud to get wifi back!
found this in log of my router, udp port scan attack, idk how can this shut down wifi?
Help please!

2019-02-05 21:28:33 Security Warning Detect UDP port scan attack, scan packet from 192.168.8.249

192.168.8.249 <— ip from mycloud home


#9

Hell, please wd crew, ANSWER!


#10

Hi @davishekwd,

I am same issue, Do you resolve ?


#11

I disabled Desktop Sync and just started using Windows File Backup to the //MyCloud-XXXX/Public share.


#12

Same issue here. Connecting the WD My Cloud Home to my wireless router slows the Wifi right down, sometimes killing it completely and preventing all my other devices from connecting. Only solution is to disconnect the ethernet cable between the cloud and the router, which makes the Cloud basically useless. If there’s no solution here I’ll have to return it.


#13

@GoblinKing Are you using WD Discovery and Desktop Sync? Try to disable Desktop Sync? What firmware is your MCH on?


#14

Mar 3.2019
model wdbctl0040htwt-00 4TB My Cloud

Just like all the other post here can we get a WD Webmaster or IT person to please post a how to fix? or a RA# to send our defective products back in for credit looks like it’s happening all over.

Please help me in resolving this I have tried several another routers, same issue.
Had my line from the road to my home checked. then by dumb luck i deduced it was only when i plugged my could 4tb NAS in to the router it would work for a bit then bam major issues like all the other post.

My Cloud kills Wireless Internet connectivity.


#15

Hi All,

I can share the information that kind of worked for me. It’s not at all a full proof solution but at least gets the job done.

FYI, Whenever I mention of reboot/restarting your MyCloud home, I mean it by directly removing the power cable from MyCloud device and not switching off the main switch or rebooting via software. Straight away pull the DC power cord from the device, wait for 2-3 sec and then put it back on

Steps:

  1. Firstly, make sure you reserve an IP for your MyCloud device. Based on your router’s model you can find the setting and make sure you reserve an IP so that every time your MyCloud gets the same IP. I don’t really know why, but this is the only way it worked.

  2. Every time you restart your router or your router reboots, you’ve to reboot (the way I mentioned above) your MyCloud. When the light stops blinking and your MyCloud is online, check whether you’re having your wifi/internet connectivity. If not, again reboot your MyCloud and keep on doing it until it works. For me this is the only way it worked, I had to reboot at max 3 times. Once it works, it won’t be a problem until your router reboots.

But, I really hope WD should call off our products and get it replaced. This cannot be entertained.

P.S.

  1. I’ve the WD Discovery updated, make sure you have it updated. Thats what I was suggested by the WD L2 team.

  2. And if possible, use a gigabit router. I’ve a TP-LINK Archer series router, the problem is less compared to my older models. But again, this cannot be a suggestion or even a recommendation.


#16

I’m curious to know what routers (modes) and network config everyone’s using in their setups that could affect wifi channels.

I use a Netgear AC1750 Cable Modem Router with My Cloud Home Duo, PR4100, PR2100 connected via Ethernet and (2) Sonos (2) Alexa, (4) iPhone (2) iPad (2) Win10 and (1) macbooks all connected via 2.4 and 5 GHz wifi and I’ve never had a problem with wifi with a My Cloud Home device connected. I also run Plex on both My Cloud and the My Cloud Home with family and kids streaming to their iPads nightly. I’ve no switches or cable modem box and connect the AC7150 directly to my ISP.


#17

finally i found a solution uninstalled the Plex app from mycloud and everything is working fine, plex is killing the router i dont know how but now mycloud and router-wifi is working stable no more problems.


#18

Thanks a lot… Disableing PLEX is so far the best solution… :slight_smile: