WD My Cloud Home killing Wireless Internet Connectivity


#1

This is brief overview of my setup
I have broadband connected to my router (Tp Link WR841n) and has wireless configured
The router is also connected to Gigabit switch (Tp Link TL-SG-1005D) via LAN (LAN port in router to switch)
I’ve my WD My Cloud Home (3TB) connected to that switch. Also my Xbox and PC

The problem,
Whenever I’m connecting my WD My Cloud, the wireless of my router is getting killed. I can connect devices via wifi but none of the devices are able to access internet (sometimes very very slow). The moment I’m removing the LAN from my WD to Switch, everything seems to work fine.

However, the LAN connection is not affected meaning when everything is connected I can access internet on my PC and Xbox with no issues, just that the devices connected via Wifi are not able to open any webpages.

Please help me in resolving them since I share my home with others and they are not able to access the internet if my WD My Cloud Home is connected

I tried Googling and tried the solutions like QoS (Bandwidth control) but no luck !!
I also have a reserved IP for my WD MCH and hence no IP conflict issues as well

I tried with another router ( DIR-600M ), same issue.

Is it because my routers are having 100 Mbps Ethernet ports and the Switch is Gigabit ?? But again how that would kill Wireless Internet connectivity


#2

@davishekwd sent you a private message requesting information.

Thank You


#3

Hi,

I have a much simpler setup, with exactly the same issue. Whenever the WD MyCloud is plugged directly into the router, all Wi-Fi connectivity is lost, or significantly reduced. I am going from receiving 40mb/s on all wi-fi devices to either zero or no more than 2mp/s. Please could you support me in fixing this.

Thanks,


#4

got same problem here, but i found a solution, the problem is the power supply from the cloud it kills the wlan i put some aluminium foil over the powersupply and voila wlan is back!
this needs an replacement from wd how to get a decent powersuply from you?

MFG


#5

Unplugged Cloud ethernet cable from router. Unplugged power from Cloud. Waited 1 minute. Reconnected ethernet cable to router. Then reconnected power to Cloud. Now working. Could probably just remove power from Cloud for a minute and have same result.


#6

Hi all,

Same problem here.
Already tried every single option i found online and none worked.

  1. alumminium foil arround the charger
  2. disconnect and reconnect,
  3. changed ethernet cable,
  4. changed ethernet port in my router,
  5. reset mycloud home
  6. disconected all automatic backups…

Anyone solved the problem??

I’m about to return my cloud since i didnt find any solution :frowning:


#7

Has anyone managed to solve this problem? The same is happening with my Mycloud home


#8

why nobody from wd can answer here? this is a common problem with my cloud home!
this really pissing me off always need to reboot the cloud to get wifi back!
found this in log of my router, udp port scan attack, idk how can this shut down wifi?
Help please!

2019-02-05 21:28:33 Security Warning Detect UDP port scan attack, scan packet from 192.168.8.249

192.168.8.249 <— ip from mycloud home


#9

Hell, please wd crew, ANSWER!


#10

Hi @davishekwd,

I am same issue, Do you resolve ?


#11

I disabled Desktop Sync and just started using Windows File Backup to the //MyCloud-XXXX/Public share.


#12

Same issue here. Connecting the WD My Cloud Home to my wireless router slows the Wifi right down, sometimes killing it completely and preventing all my other devices from connecting. Only solution is to disconnect the ethernet cable between the cloud and the router, which makes the Cloud basically useless. If there’s no solution here I’ll have to return it.


#13

@GoblinKing Are you using WD Discovery and Desktop Sync? Try to disable Desktop Sync? What firmware is your MCH on?