WD My Cloud - can not conect via mycloud.com

Hi,
I just bought new 3TB WD MyCloud NAS. Done all settings, maped as network drive.

But if i try to log in via mycloud.com is just a blank page and “Signing in…”, with no signs of signing in… From Android app I can acces my drive (via Wi-Fi, I have not tryed yet to connect by 4G), I can see photos, open them, but no video files. Player just struggles to open and gives error - could not stream…

I have just changed DNS server setiings to router to 8.8.8.8 (Gooogle DNS), restarted router and WD My CLoud - still no accsess from mycloud.com

I`ve red that article: https://support.wdc.com/knowledgebase/answer.aspx?ID=15130 and try all CMD comands - no problem there…

I am using Windows 7 64 bit.

Can you help me?

Hello there,

Try a different browser to see if this helps, this might be an issue with the web browser you are using. In case you come across the same issue on a different browser, turn off cloud access on the unit, then reboot the drive and turn cloud access back on.

Hope this helps

Hi ArMak,

I think I found the problem - AddBloker bloked the last request from the server. When I disabled AddBloker fo mycloud.com it worked.
And for not streaming to my Android phone - the problem was in the media player :slight_smile:

I had diffrent problem after that, but for that problem I think it was due to detected infected file and detection blocked the connection.

10x for help!
Wish you the best!