WD My Cloud 4TB (gen 2) does not work after connecting USB-HDD


#1

Today I bought a new WD My Cloud 4 TV (Gen2). It is connected to the router. I copied movies on a NAS. These films are available in the network. WD My Cloud was working fine. Then I turned OFF the NAS. I connect an external hard drive in USB. External hard drive is A-Data 320GB USB2.0. Then I turned ON the NAS. A long time blinking blue LED, longer than ever before. Then the LED lights up blue (not blinking). But the server has become unavailable on the network. The router did not give him the IP-address. What happened? I did everything according to the instructions. Then I pressed the reset button. Nothing changed. Then I did as instructed: “At the same time as you plug power into the My Cloud device, press the Reset button and hold for about 40 seconds”. Nothing changed. NAS is unavailable in the network. NAS is included for several hours, but he is not found in the network. He did not even go to sleep. However, before connect the USB-HDD to NAS, server was able to sleep (blue LED blinking slowly). Please help me with a problem.


#2

Alright, I’m not sure if we can get the attached USB working without crashing the Cloud but we can certainly give it a try.

  1. unplug the usb hard drive from the cloud and just leave it beside the cloud for now.
  2. replug the NAS and wait for the blue light
  3. you should see the cloud back online.
  4. head for the dashboard and turn off all your media
    Turn the following switches off

“Set Up Shares” turn Media Serving OFF
turn off Cloud access under “Settings” “General” “Cloud Access” OFF
turn off DLNA and iTunes under “Settings” “Media” to OFF and iTunes - OFF
Turning everything off will give you a bit of peace as you load up your device with files or just accessing your files locally.

  1. Wait for 5 minutes. This tactic worked about 2 years ago but with all the firmware changes it might not, but I’ve added this step here anyways. Waiting 5 minutes allows the NAS to settle down after start up.

Later when you are ready, you can then turn the scans or the remote access switch ON and let them run for a couple of days, weeks or years; I believe my WD live ran continuously for the two years that I owned it :stuck_out_tongue:

  1. now plug in your USB drive and keep the dashboard open and you should see the USB drive mount and it should show you the available space. If it keeps showing 0 available space, your usb drive might be incompatible with your Cloud as the list of compatible USB drives is very short; 1 actually and it should be a WD USB 3.0 drive. Well a few others but the list is short.

Once your drive is mounted, go to the USB drive Shares and make sure to turn off Media. This will hopefully prevent a media scan on your USB drive.

  1. If you are lucky, you should be able to access both your Cloud and your USB drive. If you are not lucky, within the next 5 to 10 minutes the cloud might drop off the network because it is being locked by the USB drive.

Give the above a try and if you do encounter a lockup the next step is to SSH into the drive and stop the media scans as well as another service, but that is for another post.

Let us know how this works out.


#3

I unplug the USB-HDD. NAS is not getting ip-address. I waited for two hours. NAS does not appear on the network. LED lights blue constantly.


#4

after you unplugged the USB HD, remember to reboot your NAS. Once it turn blue, it should be on the network.

If you cannot find it by browsing, take a look at your router to see all the devices that currently has a DHCP ip to see what ip your cloud has, then use that ip to access your cloud.

If your cloud had worked before the USB HD plug in, it should work as before.


#5

My sequence of actions:

  1. Turn off the NAS
  2. Unplug USB-HDD
  3. Waiting for 2 minutes
  4. Turn on the NAS
  5. LED blink blue quickly. (3-4 minutes)
  6. LED lights blue constantly
  7. Take a look at your router to see all the devices that currently has a DHCP ip
  8. Only the computer has ip-address. Only one client.
  9. Waiting for 10 minutes.
  10. Take a look at your router to see all the devices that currently has a DHCP ip
  11. Only the computer has ip address. Only one client.
  12. Turn off the NAS. Repeat steps 3-8
  13. Waiting for two hours.
  14. Take a look at your router to see all the devices that currently has a DHCP ip
  15. Only the computer has ip address. Only one client.
  16. Turn off the NAS.

#6

17.Pressed reset 4 seconds. No result.
18.At the same time as you plug power into the My Cloud device, press the Reset button and hold for about 40 seconds. No result.


#7

Miracle! After four hours without power server is running.


#8

btw. you never need to wait for two hours, or four hours… but there are exceptions I’m sure…

ok good job…


#9

But why it works? I did not do anything additionally. I did not change anything for those four hours.


#10

One of the things we learn as Users of this My Cloud product is to be patient.

The most likely answer is that the 40 second reset took between 2-4 hours to reset. It depends on the number of files you had on the device because I believe it resets all the permissions for all the files.

However now you can move on to the next step and that is to turn off all media settings and then while the cloud is still on, go to the dashboard to watch your USB hard drive being mounted. Now plug in your USB hard drive.


#11

Hi there,

I’ve taken out the USB from the cloud but my light is still red and still offline. I’ve had the cloud for about a year now not had any problems with it till today. I keep getting told that I need to update but I cant even access the desktop to my cloud as it keeps telling me it cant connect to my cloud. I am not very computer lit but I have tried everything can you please help. Many thanks in advance


#12

Hello all,

This is my similar issue.

My cloud 4TB is working properly but when I connect a USB-hdd 1TB, My Cloud starts not responding, after 2:28 hours I shutdown My Cloud.

I think My Cloud is scanning the USB-hdd 1TB.

This is the top of My Cloud

top - 23:30:28 up 2:28, 2 users, load average: 14.04, 13.96, 13.66
Tasks: 86 total, 4 running, 82 sleeping, 0 stopped, 0 zombie
%Cpu(s): 0.5 us, 97.9 sy, 0.0 ni, 0.0 id, 1.3 wa, 0.0 hi, 0.3 si, 0.0 st
KiB Mem: 230560 total, 138676 used, 91884 free, 1000 buffers
KiB Swap: 0 total, 0 used, 0 free, 12012 cached

What can I do to avoid that?

Thanks