WD My Cloud 3TB - Solid Yellow Light - No Access - iMac

Hi All,

Need help.

I have been using WD My Cloud 3TB, for my Back up directly connected to Mac Ethernet Port occasionally. Direct Back-up, no software or Time-Machine. But since almost a year I have kept it connected to iMac regularly for Access. Even if I don’t use it, My Cloud is connected to the iMac. I think it is Gen1 as bought initially when it was released and also the P/N starts with 00.

Well last week the LED in front turned RED for a bit and then Orangish-Yellow [Solid] since then it has been the same with no access whatsoever. Unable to access via Wd My Cloud Software or connecting server via Command-K. Tried BOTH RESET methods [4-Sec + 40-Sec] but light doesn’t react at all. It is Yellow the moment I connect the power Cable, doesn’t change to any other colour and then Yellow. I can feel the HD trying to read when touching it other than the soft buzz it has, then I check the Ethernet light at the back and it is Blinking initially but stops after few seconds.

Other day, suddenly while trying to connect constantly including changing Ethernet cable, it turned Red [Solid] so I shut it down. I read that Yellow [Solid] and Red [Solid] could be due to Heat so I cooled it down and connected after almost 7 Hours. The moment I connect the Power cable it is Yellow [Solid] again. So as of now NO DETECTION on Mac at all.

Have emailed WD Support and will speak to them also today.

What are the alternate access for a Mac user?
Can I remove the HD and access it with a HD/Sata Docking Station?
Can I get access using Mac Address / IP?

Any help would be appreciated.

After letting it cool down and then plugging it back in how long did you give it to boot up and maybe turn blue?
Mine takes between three to six minutes to fully boot up.

Packed it up and kept it away for a month and switched on. Same light - Stable Yellow. Still no access.

Could I remove the Drive from this casing and use in a Hard Drive Docking Station to a Mac and access files? Unable to access directly from Wd MyCloud and need to retrieve files.

It is just a Linux partitioned sata disk. You should be able to access the disk.

Thank you.
Would I be easily able to access the files on Mac?
Would I need 3rd Party Software etc. to retrieve them from the Hard Drive Docking Station?

Really Appreciate it.

you will need software for your mac to mount the drive… as it’s formatted Linux EXT4


Thank you Joey. What software should I get for the Mac to access the files?

As per my linked thread, try Paragon software…

I also have a My Cloud 3TB ( probably 1st generation ) and have had it for 2.5 years or so. Worked fine until a month ago. Then all of a sudden the blue light went away and then no light . And no connection. No dashboard. Nothing. I tried a number of solutions before finally calling WD support. Walked through a few different attempts to get it going with WD support people. They did a good job including taking charge of my computer. And we did the 40 second reset and still nothing. I am afraid I have a non-working device and I am ready to go through the steps to remove the HD from the enclosure and place it in a SATA enclosure and use it as an external USB drive. I have a Mac Mini that I plan to connect it to it. Problems I will encounter? Reformatting ? Linux questions? Any advice ?