WD Media Server - srt support?


Just wondering if WD Media Server will support srt files? My Samsung tv is not picking them up.

Hi, check if the link below helps. 


OK, my mistake: srt files DO work with my Samsung tv! I was watching a movie which I forgot to add the srt files onto the MyBook :slight_smile:

OK… there must be some kind of serious glitch, because I can’t pick up ANY srt files on my Samsung tv anymore. I’ve checked and all the movies I have on my MyBookLive have separate srt files. For a while I was picking up the subtitles, but that seems to have stopped now. I just spent a couple of hours trying to embed srt files into mkv, but that doesn’t seem possible. So the other option is to change the mkv files to mpg, but that will take hours.

Is WD monitoring this forum? Because I have this problem, and also the problem I describe here:

WD Media Server on MyBookLive - every file in the library is the same


Going a little nuts here. Hope someone can help me resolve this!

Hi everyone,

I’ve just bought the WD MyBook Live, updated the firmware and cant see external subtitles in my tv. With TVMobili installed on Win7 everything was working ok, now I can’t see the subtitles.

If I understanding corretly (after research on Internet) my device has the WD Media Server is that correct?

To see external subtitles change the server will be necessary?

I ended up doing a rebuild of the database. That solved my problem of the srt files, but NOT the problem of all files having the same file name…

Hi Jose,

When I bought mine, it had Twonky Media Server. I had to manually upload a new server to the MyBook, which made it possible to play mkv files to a Samsung tv. If you have a Samsung tv, you should see if you have Twonky or if you don’t. If you don’t have Twonky, I’d guess you have the WD Media Player. GUESSING though.

Powernout wrote:

I ended up doing a rebuild of the database. That solved my problem of the srt files, but NOT the problem of all files having the same file name…

Did you delete .wdt folder?  Cause you shouldn’t be seeing duplicates like that unless you’ve been moving files and folders around.

I’ve checked and I have the WD Media Server and the problem is it. I can’t find help to see subtitles with WD Media Server, all the help I find is for the ones who has Twonky. 

I think I’ll install the Twonky!

Hi Bill_S,

Thanks for your answer! Apologies for not getting back to you sooner. Responses are sent to my hotmail, which no longer gives me popup messages via Skype. I’ll change email address in a minute.

The only thing I did was update to  Firmware Version 02.42.02 – 012.  I believe I did this by choosing Update from File in the MB Live Dashboard. I didn’t delete anything! And I haven’t been moving files around either. 

Should I delete the .wdt folder? And if yes, where do I find it?