WD Live can't connect to WD NAS Drives as a Network Shre!

#1

WD LIVE TV box has been working for years no issue. It is connected to a Buffalo Drive that only ever showed up as a media server - the two WD External drives showed up both as “media servers” and were also listed under “Network Share” drives.

I always connected the WD boxes as a “Network Share” as it nicely linked the “movie.mkv” with the “movie.jpg” to give me nice thumb nails.

I can still see the drives and play the movies under “media server” but when I try to connect them via “Network Share” it keeps asking for a username and password. I never recall setting up an username or password. I’ve now logged into the WD drive and allocated a username and password and tried that but it does not work. I’ve reset the WD Live box (all but logins option) but no difference.

This does not seem to be a network issues - as I can see and play the movies, but my user experience is is messed up as I can’t do what I have done for years and I can’t see the thumbs I created over time.

#2

This old thread of mine will likely solve your problem. It describes the issues with passwords and network shares. BTW, the drives connected to your WDTV are not “NAS drives” They are simply network shared drives just like any drive plugged into a computer.

#3

Thanks mike - this is my point. I never had a password set! it always worked!! Then yesterday it kept asking for a username and a password!! I never had set one on the WD Books before!! it had an admin with no password set, for the very reason you said - it’s just movies and family photos.

The ONLY reason I set a password is to try and get around this issue - but it does not seem to make a difference. So the issue is the fact that it is asking for a passwords and keeps complaining “invalid password”!! Even when I enter a user I just created with a simple 123456 password. I don’t think there was an update, it usually asks me so I can control when the update happens and if I want it at all.

#4

The point now is: Since you now have a password, the instructions can help you remove it correctly! BTW, unplug the WDTV, wait a few moments to plug it back in and see if you can get back to having no password again!

#5

Really appreciate your prompt help here, but no change :frowning: powered down and restarted and checked - no change. So followed the instructions - there is no auto-login option so I ignored that part (as instructed) and cleared all passwords - but again still prompts for a password and then says invalid.

Any other ideas?

#6

Try restart of WDTV after making changes. If all else fails reset WDTV to factory defaults per the manual and set it up again.

#7

Tried the restart and still nothing - it’s late here in the UK so I will work on the total reset tomorrow. Thanks.