WD EX2 Ultra unreachable after a while

Hi, new here…

I’ve been using my WD My Cloud EX2 Ultra for over a year now, and there were never any problems.
Until now.
Setup is a 4 TB raid 1, firmware is at the latest level.
A few days ago I noticed that the device was no longer reachable. Pinging the device times out.
I can get the device back in working order by unplugging the power supply, and plug it in again.
After that, the GUI is reachable again and everything seems to be in order. No errors in logs…

Then, after a some amount of time (hours, sometimes days) the device is unreachable again, and again I can’t ping it.
Did both the 4 second reset (no dice) and the 40 second reset (no result as well), but the issue remains.
I’ve seen posts here that resemble my problem, but no solution was found, so I’m struggling here for help.

If anyone here can enlighten me how to pin down the exact problem, and what can be done to fix it permanently, I would be very grateful.

Oh, one more thing : The only extra app I installed was Plex. Since Plex had an update I recently updated it. Not sure if this causes the problem.

Thanks

Any updates on the PC recently? Or router?

Does this affect one PC or more than one PC?

Fixed IP?

My money is 50% on the router. . . however . . .if resetting the EX2 fixes it. . .then that increases the odds of the EX2. I presume from the lack of GUI and pinging. . .you can’t reach it via WD.com or a file browser either?

Thanks for replying…

No, everything else in the LAN works perfectly. No network issues whatsoever.
And yes, rebooting (unplugging the power) does fix the issue, but only for a short while.
When the issue occurs, I can’t reach the device in any way…no ping, no ssh, no file browser, no http…
Nothing…

@phloks Please send me a private message with your case number and include the make and model of the network router as well as recent My Cloud system logs. I will have someone look into your issue.

Hello @SBrown, I’m having the same problem. I had it with my WD My Cloud first. We now bought the WD My cloud EX2 Ultra, with the idea that this would fix it as it’s a new version of the My Cloud that we had for a longer time. It worked perfectly when I installed it yesterday, now this morning I want to go back in and I’m again refused. I can get into the WD my cloud EX2 Ultra without a problem, I’m even still logged in as admin and I can get into other files, but going to my folder (idonea) that I want to get into it gives me this notification ‘The operation can’t be completed because the original item for “idonea” can’t be found.’ I had this problem with the previous WD as well. I needed either, re-connect through finder, restart my computer and hope for the best. This will work for a few some time, sometimes a few minutes, hours or even for the day. But I’m tired of reconnecting it and now that I’ve spend more money on something that gives me the same problem it’s nicely said freaking annoying. Can you please help me.

@Idonea The issue you described is directly related to macOS client computer Bonjour loosing the share name. Please refer to the following KBA for solutions but you may need to consult with Apple Support for more technical solutions regarding macOS Bonjour client services.

My Cloud Cannot Reconnect to Shares on macOS
https://support-en.wd.com/app/answers/detail/a_id/29449

Hi @SBrown, I don’t have MacOS Bonjour if that’s what you mean. I got Catalina. I’ll look at the link you send. Only I’m not happy about the idea of constant reconnecting my finder to the WD or even shutting down my computer. We also brought back the WD my cloud EX2 ultra, as it kept having the same problem as the first. Which still works, but we thought it wasn’t right for mac anymore, we’re now back using the My cloud (white one). And I hope the solution that you gave will work. But I’m not to pleased about the fact that I’ve got to call Apple for help as it’s a product of you and not them. Also I had contact with Apple to find out if they had a similar product that would work better with mac, they didn’t and the person on the phone couldn’t help me with the problem. I’ll try to find someone who can from Apple, but still I’m not pleased that there isn’t an answer to this.

As I read the link you send me, it means that I’ve got to do the same thing that I’ve been doing. What bothers me is that when I open finder after my computer has been shut down and restarted, that I can connect (2 times out of ten) and when I close that finder window, or leave open for a long time without working in it, it just disconnects and I can’t get back in. I then try to reconnect by connecting to the server, through finder or the go option. Which is annoying like crazy, I want to connect ones to my WD my cloud, and not go and reconnect every single time (which is multiple times a day) manually. I bought this product to have an cloud connection to my files, not to play reconnect games with it. Is there a solution that my computer or wd (as I don’t know who throws who out) can keep their connection and love each other like any happy device does?

@Idonea Bonjour is a networking service that is managed at the client computer and not the NAS device itself. If Bonjour disconnects and cannot remember the share name “as the error message indicates on macOS”, the issue would be on the macOS client computer side and not the My Cloud or any other NAS product side. The My Cloud doesn’t manage the client side computer connections.

More information can be found in this Apple Discussions thread.
https://discussions.apple.com/thread/250796514

@SBrown

I have a newly purchased WD MyCloud EX2 Ultra 8TB.

The status of all 3 led are steady blue. I do not know the firmware version since i cannot access the WD MyCloud.

I lived in the Philippines and my internet provide is PLDT with PLDT FIBR modem model AN5506-04-FA (2134285-f1a)

I already try resetting the modem and restarting all the devices but still not working.

I’ve been searching and reading related articles by to no avail.

hope you can help me. thanks

other details:
Ticket No: 200804-005012
OS: Windows7 Ultimate

Hi EX2 Ultra has been a disaster since I plugged it in yesterday, I chose WD because I thought this was for newbies getting into the NAS game.

I am having the similar issue, I have rebooted the device and I still can’t connect to the mycloud. It is showing as device offline.

The mycloud page suggests
Ensuring there is an interenet connection - there is.
checking if I have the latest firmware version. I am currently running 2.31.204. When I try to update it says it can’t connect to the update server.
Accepting the devices Certficate but when I click the link I’m not able to click advanced and accept the certificate instead I get an error message.

Your connection is not private

Attackers might be trying to steal your information from device8204588-97633dd6-local.wd2go. com (for example, passwords, messages or credit cards). [Learn more](chrome-error:// chromewebdata/#)

NET::ERR_CERT_INVALID

Help improve Chrome security by sending URLs of some pages that you visit, limited system information and some page content to Google. Privacy Policy

ReloadHide advanced

device8204588-97633dd6-local.wd2go. com normally uses encryption to protect your information. When Google Chrome tried to connect to device8204588-97633dd6-local.wd2go. com this time, the website sent back unusual and incorrect credentials. This may happen when an attacker is trying to pretend to be device8204588-97633dd6-local.wd2go. com, or a Wi-Fi sign-in screen has interrupted the connection. Your information is still secure because Google Chrome stopped the connection before any data was exchanged.

You cannot visit device8204588-97633dd6-local.wd2go. com at the moment because the website sent scrambled credentials that Google Chrome cannot process. Network errors and attacks are usually temporary, so this page will probably work later.

I can access the device via finder (Mac OS) and can see the folders. Timemachine backup works but is extremely slow.

IOS app is the same i can logon but nothing syncs.

I presume that you are talking about directly accessing the machine; not going through mycloud.com?

First. . .figure out the ip address of the machine. When you first power up, I believe it is defaulted to DHCP. . . so you have to look for a new device in the Router.

With the ip address, you can type it in a web browser address bar to get to the web dashboard.

You can also put “mycloud.com/setup” in the address bar. . .and I think you wind up at the same place.

This is all explained in the manual. . .download it. . . .ok I looked at the manual. Wow that’s a bit much. . .not how I would do it. But it will get you there.

To get to mycloud.com. . . the best way is to setup port forwarding in your router. The defaults for external ports are probably 80 and 443. . .which may be blocked by your ISP. The internal ports are more than likely ALSO 80 and 443. . .which is fine; since they are dedicated to the device itself.

The trick is to assign two ports external ports that the ISP (or your firewall) isn’t blocking (say, 9080 and 9443). . .and forward them to appropriate internal ports on your EX2. So if your cable modem has an external IP address of 22.45.33.140; an external port (to the world) would be 22.45.33.140:9080. If your EX2 is sitting at 192.168.0.2 on your network. . .the appropriate INTERNAL port would be 192.168.0.2:80

I think you can also do this within the EX2 ultra. . .navigate to “settings”; “Network” and “port forwarding”. Click “ADD”. Then “customize a port forwarding service”. Call the service what you want. Protocol TCP works… . the external port would be 9080 and the internal port would be 80 (80 is the internal HTTP port on the EX2) Then create a second service (for HTTPS connections) with 9443 external and 443 internal.

Let me know how it works out. . .I actually have not done it; I prefer to do this from the router itself; as I have one or two more devices on the network that want dedicated ports.

To judge success: Go to “Settings” “General”, “Cloud Access”. If “connection status” is connected; mycloud.com should work. If it says “Port forwarding connection established” you are done. If it says “relay connection established”. . .you are half done. . .and mycloud.com is just making a (good) guess regarding settings.

Just to update everyone I have updated to the latest firmware and rebooted the device however I still get the same message when I login to mycloud in chrome:

Can’t connect to MyCloudEX2Ultra

Here’s what you can do to try and fix the problem:
Make sure your device is powered on and connected to a network with Internet access.
Accept the devices security certificate.

When I try this in safari it seems to work.

The app is still useless autobackup ups don’t work

Hi NAS_user thanks for responding. I am talking about the access to the cloud via web browser not the dashboard. THat’s where I get the message to check those settings. It seems to work on safari but not chrome. I tried setting up autoback up on the mobile app and I just get 000’s of 0kb files, some images show but the majority do not. And some file formats like .mov and mp4 apparently are not compatible and cannot be opened.

Ah - - - the difference in use cases.

I never quite understood the desire to access files via a web browser.
You know. . I think I have heard about that security problem that before regarding Chrome.

can’t speak to the autobackup options.

I have been struggling with this for more than 6 months. My MyCloudEX2Ultra 2-bay NAS with 2 6 TB disks worked flawlessly for 2 1/2 years (locally, via my Android phone and iPad, and the WD web interface). Then I shut it down because I needed to do some electric work in the house. After the restart it was visible as ever, but after some minutes it suddenly disappeared from the network.

What I do not understand is why the thing would work flawlessly for months and months without the slightest hiccup, then drop off the network after an orderly shutdown and restart when all settings remain identical. I also don’t understand why in such cases trying to access the dashboard in my browser would give me a “Connection refused” error message. Apparently, the unit is still doing something, but it is not accessible via browser, Windows, o the cloud. Finally, the Media server is usually still accessible for a while when the dashboard is not, but it too will after an hour or so succumb to whatever is causing this problem. Mind you, I am on my second unit (warranty replacement) and seeing the same weird behavior as on the previous one.

While this is happening the drive will not go into sleep mode any more. All thre LEDs in front are steady blue. There is lots of network activity on the NIC in the back. After I power-cycle the NAS (there is no other way to restart it when it hangs), it will be accessible for a short while (15-30 minutes) then the same symptoms.

With the help of WD support and this forum, I tried 50 different things, including static IP, enbling SMB1, disabling sleep, turning off various services, connecting it directly to the router rather than a switch, turning off the firewall, 4-sec. reset, 40-sec. reset, but only the 40-sec. reset restores functionality (with sleep enabled), until I have to shut down the device again for some reason. Another 40-sec. reset restores the connection, but I cannot be doing this every time I restart the darn thing.

Since the NAS was still under warranty I got a free replacement from WD. I set it up and it worked flawlessly for 4 months, until I purchased a UPS and had to shut the NAS down to connect it. I was obviously half expecting this, and by now the device is out of warranty. So it is time for another 40-sec. reset.

I will never buy anything from WD again. These devices are not cheap, they cannot be used as other Linux boxes from QNAP etc., and support is completely clueless. For instance, why would I need to mess with network, firewall, IP etc. settings when the darn thing works flawlessly for months, and after a restart continues to work for a while, it then drops off the face of the earth? The forums are full of these issues, yet WD does nothing substantial to address them.

I use a static IP on the router mapped to the MAC address of te NAS.
The NAS is set to get its network config via DHCP from the router.
Workgroup name is unchanged (“Workgroup”)
Time zone is set to my local time zone (Vienna)

@MonteChristo Can you send me your support case number?
How are you powering off your EX2 Ultra? Are you logging into the dashboard and Hibernating the device or removing the power plug from the unit?

Here they are in reverse chronological order (most recent first):

Case #013020-14441264

Incident: 200410-002577

WD Case (011720-14412178)

WD Case (010620-14383003)

WD Case (052919-13858627)

Let me know if I can provide anything else. Regards,

EK

Sorry, @SBrown, I did not answer your questions. I am unable to access the dashboard (Connection refused), so i cannot restart the NAS that way. WD Access has a Shutdown command, but it does nothing when the problem occurs. So the only thing I can do is power-cycle (pull the power plug, wait 10 seconds, and reconnect).

I can also not ssh into the unit. Putty just hangs there, no error, no timeout.

There are plenty of others experiencing this issue: