WD EX2 Ultra - Connection refused

Hi,
I’m after some guidance in narrowing down the problem, since support is taking too long to do anything useful.

My setup is a EX2 Ultra NAS connected to a switch that goes to the router. In my LAN I have 2 computers (Linux) connected to the same switch and another 2 (Mac OS, Linux) connected via WiFi. Besides, there’re 2 iPhones in the house.

I have disabled remote access in the dashboard. Firmware is latest. All network setting are default.

All the computers are able to ping, connect to dashboard, mount shares via NFS and SAMBA, and the MyCloud app on the iPhones also work fine.

However, even though the MyCloudEX2Ultra shows up in the network devices in the file browser (or Finder in MacOS), none of these computers are able to open and login when double clicked. According to the manual, an authorisation page should pop up, but instead I get “Could not connect to MyCloudEX2Ultra: connection refused”.

Any clue of what might be causing this?

Hi haphaeu,

Please check your Private Message.

I have the same problem… How about a solution that is publicly available ?

1 Like

Same problem here too. I can’t get it to connect. Its not showing up in the Finder in my MacOS.

I’m connecting through a switch that goes to our router. I’m hoping to find a solution, please post if you find out how to resolve.

1 Like

The WD Experience is as horrible as it gets… More than 750 Euros for this.

I tried to activate IPV6 and port forward on a static IP, it didn’t work, went back to DHCP IPv4 and IPV6, deleted all newly added IPs, including the DNS, I validate my choice, the device asks me to relog in and presumably wants to take me back to the login screen. And Tadah, Access refused, there is no way whatsoever to reach the device’s Dashscreen. Device is presumably offline when all the lights are blue and it’s humming.

Not to forget that today morning i had to plug it out to make it work, cause I could access the Dashscreen and the settings, but no command I had given was taken into account, I couldn’t make it hibernate, restart or make it check the system files.
Solution: Hard reboot, then a reset to factory settings.

Sad thing now is I’ve run out of solutions to solve the problem i’m facing now: No way to access the Ultra ex2. Such a pain in the … bugger on my birthday.

What in God’s world is wrong with these devices, is it the new update?

alex.s

Oct '18

Hi haphaeu,

Please check your Private Message.

Please DON’T respond to forum members like this. If you have a potential solution, post it here so that others with similar problems can try it. If you don’t have a solution, then there’s no need to post or send the OP a PM.

If you did a 40 second reset, this should reset all passwords. Did you do a 40 second reset or a 4 second reset?

Just to update that the problem is still “pending”.

Luckly for me I found ways around. Using linux, the NAS drive is being successfully mounted via:

sudo mount -v -t cifs //192.168.10.84/share/path      /mnt/nas/share/path -o username=myusername,uid=myuid

The password will be asked. I put that in a script:

read -s PASSWD
sudo PASSWD="$PASSWD" mount -v -t cifs //192.168.10.84/share/path      /mnt/nas/share/path -o myusername,uid=myuid

If that is acceptable, the drive itself is working nice and steady for over a year and half now.

Now the MacBook is another story, which also for my luck is not being used any longer, so no developments there from my side. But I believe OSX should have a similar command line interface via the mount command.

Also worth noting: from my experience, avoid using the NFS protocol since it is unsecure - either open for all IPs, or restricted to 1 IP only due to a silly restriction in the interface. I’ve tried to change the system’s files in the NAS (via SSH), which did work nicely, but the configuration got overwritten in the next boot. So, don’t recommend to do that either.

PS: by exploring through the system’s files in the NAS drive operating system, I also found out that the thing does send data to WD regularly (more than 1x a day). It is low level system indicators, nothing personal, but still I was quite bothered by that… if you want to see just check crontab -l and follow the yellow brick road…

I am getting

mount: /mnt/nas/public: mount(2) system call failed: Connection refused.

I am also getting “Connection refused” when trying to access the dashboard in the browser. I am on my second NAS after a free warranty replacement. Same BS, only now I am out of warranty. Drive works fine for a while, then vanishes from the network.Dashboard cannot be accessed. Media server works for a while, then also quits. I do not know what to do.