EX2 Ultra dont have cloud access


I recently stopped having access to cloud service. ex2 ultra says no cloud connection.

Connection Status Failed
Cannot establish remote access connection. Make sure you are connected to the internet.

I didnt touch anything from previous connection config.


Hi Tatschcke!

Several users have been experiencing the same problem over the past 24 hours. There are quite a few posts with the same complaint and error in the new messages list in the community forum.

It appears that Western Digital updates a few undefined features in its web servers for the MyCloud service at every month’s end and these changes affect the local connection to the web.

The real issue is that the message you get locally makes it look like it is your problem, not theirs. And this is worsened by their lack of acknowledgment of the service disruption until it is fixed, several days later.

The only course of action is waiting for them to realize there’s a problem.

If you use the system professionally, this is a real showstopper.

Keep looking in this thread and checking your server messages, it may be resuming correct operation later without any action on your part. I know I tried to reconfigure my NAS today to verify if it was me and it is definitely not me :slight_smile:



Hi Alessandro,
I agree 100%!
WD, shame on you!


thank you so much for your answer alessandro! I check all port forwarding, even try DMZ, and nothing worked. It was working perfectly two days ago. Well I’ll just wait and see whats going on!



Ya, me too. Being tried almost a day, still can’t log in mycloud EX2Ultra.
Its ignoring, if we can’t used on remotely for the NAS.

Thank you.

Same problem here. I think I’m done with this MyCloud stuff. It goes too often and when I’m working from home, it puts me at a standstill. Very upsetting that there’s no information about these outages.

Looks like I’m looking into paying for a VPN, which I am tempted to do, even when this service is work the way it’s supposed to.

The problem seems to have been fixed at this end. Give your MyCloud devices a try.

No improvement here.

I still cant acces to my NAS through web browsers. What about you guys?

It works now. Good gravy, the workday is basically over. Looks like I’m burning the midnight oil tonight.

1 Like

Hey guys! Can access now, problem solved… all day fukin up my brain and it wasnt my fault! xD

Thanks to everyone!