Cloud access disabled?

I picked up the EX2 Ultra, got it home and put the drives in. Got every thing setup and got the message of the firmware update, did the update and everything smooth UNTIL I tried to log into the Cloud access. Status says “disabled”. Try to log in or even create an account and the screen just stays stuck at “updating”.

Did the 40 second reset and after a LONG “updating” screen it says “something went wrong, check your internet connection”. Try to log in from a mobile device using the proper creds and I get “found account but did not find a compatible NAS device”

So??? Any help or do I just need to return this and get something I don’t have to fight with just to get the basic features to work?

@Dep915 It sounds like something is blocking communications with the Cloud Servers. IE: Name Resolution Failure, Firewall, Parental Controls, etc…

What network router and ISP are you using?
Can you collect the system logs and send them to support?

Thank you! I was able to copy the log and take a screenshot to send to support. I filed the online request and I suppose for them to respond so I can send them the logs and screenshot? Thank you again in advance for the help.

I have exactly the same error. I’ve spent ages on chat with WD and confirmed internet access, all n/w and setting correct, and all they suggest is to do a 40 sec full reset that regardless of how many times it is done makes no difference. Which is basically a way for them to dump the call by saying the rest will take a while try it and then contact us again if no change.

@rufusstone Did you open a Support Case? If not please use the below link and then share the reference number with me thru private message. Also if you can get a system logs and attach it either to the case or send it directly to me, we will investigate on the issue.