WD Elements 2TB Doesn't work


I have bought a WD Elements 2TB and it doesn’t work anymore.

I have connected the external drive to my PC and it worked fine until I have restarted my computer.

After the restart it doesn’t work anymore. It doesn’t show in Disk Management or My Computer. I have tried using different ports, using and extension cord and reinstalling my usb ports… but it doesn’t show up anymore.

Is there anyway I could make it work?

You can try connecting the drive to another PC or running a DLG test.

How to test a drive for problems using Data Lifeguard Diagnostics for Windows 

I have run a DLG test, it only shows my internal hard disk,but the WD Elements doesn’t show here either.

I have also plugged it to another computer and there’s no reaction.

When I comment the WD Elements, it boots up, the blue light is on, it sounds normal but it is simply not recognized by the PCs.

Did it break from connecting it to the PC the first time? I transfered around 10GB on it when it worked if it has any relevance to the problem at hand.