My WD Portable Elements 2 TB doesn't work

Hi everyone,

I just bought a WD Portable Elements 2TB external hard drive, but it doesn’t work. I have a PC and I’m using Windows 7. When I plug the HD in on the USB slot, it appears in “My Computer”, is assigned a letter, etc. When I open the hard drive, I can even see the files that Western Digital apparently put there: readme.pdf, autorun, etc. But I can’t seem to open any of those files and, when I try to copy a file on the hard drive, Windows says that it cannot be found. When I try to format it, it says that an application is currently using it (which as far as I can tell is not the case). When I ask Windows to format it anyway, it tells me that it failed. Any idea what my problem could be?



Also, I have tried to use WD Data LifeGuard Diagnostics, but the drive is apparently not recognized. The hard drive in my computer (which is apparently also a WD hard drive) appears among the “physical drives”, but the external drive only appears among the “logical drives” and therefore I can’t run any test on it.


I would recommend re-formatting the disk drive from within Microsoft Windows Disk Management, as explained in the following link:

Thanks, but I have tried, and it doesn’t work. When I try to delete volume, I get an error message. When I try to format, same thing. The first time, it tells me that the hard drive is currently being used and asks me if I want to continue anyway. When I say yes, it gives me an error message. And when I try again after that, I get another error message.