WD Discovery Installation/Javascript Errors

Hello WD Community, I hope you can help ;(

I’ve recently bought a WD My Cloud HOME device and been trying all night to connect it up with my computer. I have everything plugged in and setup on 2 computers but my main computer where I had started with first is giving me multiple errors from java. Below I’ve linked screenshots with what I have so far.

So after downloading WCDiscovery it adds all the files in it’s chosen location

It will then proceed to try and start itself will return javascript errors and not start the install program at all.
http://prntscr.com/hgj06h x13 times pop up.
http://prntscr.com/hgj0bb x3 times pop up.
After clicking on “close” 16 times the popups stop appearing.
Afterward, you can see that 3 sets of the program are running in the background
None of the 3 programs or anything to do with WD Discovery is loaded on the taskbar or icon bar.

Hope I’ve given enough detailed information.

P.S:

  • Java is fully up to date with latest as of 28/11/2017
  • I’ve tried closing the programs in processes and restarting computer multiple times before and after fresh installs of Java & WD Discovery.
  • I’ve tried running the WD Discovery program as administrator.

Really hope you can help.

ReeceH

Could only post 2 img links so here is 2 more for added info:

So after downloading WCDiscovery it adds all the files in it’s chosen location: http://prntscr.com/hgizgd

Afterward, you can see that 3 sets of the program are running in the background: http://prntscr.com/hgj1di