WD Discovery installation error - Java issue


I am trying to install WD Discovery on a brand new laptop with Windows 10 x64, Java version 8 Update 151.

Whenever I try to install WD-discovery.exe I get the following error:

28 PM

Is there something I can do to prevent this from happening?


Could someone please help me with this issue?


Same I have on Win 7 64.
Whats happaned ?

Hi an2sim, did you try to troubleshoot on your own?
I did without any luck.

I installed it without issues on another PC with win 10 Pro x64, but I am having issues installing it on this laptop.

No replies so far.


Try this:

  • Unintall and Remove WD Discovery and all residual files
  • Reboot Computer
  • Update Windows and Java (will force reboot anyway)
  • Install WD Discovery as Administrator

Hi @SBrown,

I have tried both options, running with AV+Firewall down - No luck.
I have also tried removing all traces of the installer, and didn’t have any luck either.

Can you think of anohter option? Do I need a particular Java version?
The error I get is Java related.


I have also did every “uninstall” and again “install” options. Cleaning registry , etc. No Luck.
Same error.

On another Intel based PC i did successfully.
Could it be that this is some AMD related errors ?

Hei ezerusso, what kind of CPU you have on your laptop ?

I am installing it at an Intel i7.
I did the same install on another PC and had no issues.

For some reason, I can’t make it work at my Laptop.

I think i figured this one out everyone…I was getting this error constantly the last few days that WD Discovery would not install but then I thought about it and then I attempted to uninstall any programs or software I already had installed that was related to the software already included in this pack and it fixed my issue immediately and installed right away…I had WD Drive Utilities already installed which is part of this pack as well so after I uninstalled that it let me Install WD Discovery which included WD Drive Utilities…Seems to have a conflict with its own software when they are installed separately instead of the whole pack, registry problem maybe?..Hope this helps!

I’m having a similar problem with the install, running win 10. get 3 errors that I have to acknowledge with property value Null in JavaScript.